Bug #1432

subnet gateway infos only saved when fill gateway and dns fields

Added by Florian Koch over 2 years ago. Updated over 2 years ago.

Status:ClosedStart date:01/05/2012
Priority:NormalDue date:
Assignee:Florian Koch% Done:

100%

Category:-
Target version:1.0
Difficulty: Bugzilla link:
Found in release:
Story points-
Velocity based estimate-

Description

Hi,

fix bug from ttp://www.theforeman.org/issues/1361#change-4337

the informations in the subnet form only saved if you fill the gateway and one dns fields.
the cause is the validation in models/subnets.rb
whyever the :allow_blank should work, but i need to add :allow_nil also to get this working

rgds florian


Related issues

Related to Foreman - Feature #1361: Allow subnet information to be accessed from provisioning... Closed 11/28/2011

Associated revisions

Revision 8cc2722d
Added by Florian Koch over 2 years ago

fixes #1432 - subnet gateway infos only saved when fill gateway and dns fields

the informations in the subnet form only saved if you fill the gateway and one dns fields
the cause is the validation in models/subnets.rb
whyever the :allow_blank should work, but i need to add :allow_nil also to get this working

Signed-off-by: Florian Koch <>

History

#2 Updated by Florian Koch over 2 years ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF