Bug #17611

Unlocalized strings in details page of Configure -> Smart class parameters.

Added by Daniel Lobato Garcia 12 months ago. Updated 11 months ago.

Status:Closed
Priority:Normal
Assigned To:Daniel Lobato Garcia
Category:Internationalization
Target version:Team Daniel - iteration 6
Difficulty: Bugzilla link:1343840
Found in release: Pull request:https://github.com/theforeman/foreman/pull/4097
Story points-
Velocity based estimate-
Release1.14.0Release relationshipAuto

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1343840
Description of problem:
[ALL LANG] Unlocalized strings in details page of Configure -> Smart class parameters.

Version-Release number of selected component (if applicable):
Satellite 6.2.0 GA Snap 12.0

How reproducible:
100%

Steps to Reproduce:
1. Access Satellite login page with target locale.
2. Click Smart class parameters.
3. Click on any parameter name from the list.

Actual results:
[ALL LANG] Unlocalized strings in details page of Configure -> Smart class parameters.

Expected results:
They should be localized.

Additional info:
Please see the attached screen-shot.

Associated revisions

Revision df375d35
Added by Daniel Lobato Garcia 12 months ago

Fixes #17611 - Localize smart variables strings

This commit rename removes the prefixes of LookupKey from model
attributes so that we can reuse the same strings across smart class
params and smart variables.

Revision 98bc1236
Added by Daniel Lobato Garcia 11 months ago

Fixes #17611 - Localize smart variables strings

This commit rename removes the prefixes of LookupKey from model
attributes so that we can reuse the same strings across smart class
params and smart variables.

(cherry picked from commit df375d35cf8e05885be372499b94c78f3a06def6)

History

#1 Updated by Dominic Cleal 12 months ago

  • Subject changed from [ALL LANG] Unlocalized strings in details page of Configure -> Smart class parameters. to Unlocalized strings in details page of Configure -> Smart class parameters.
  • Category set to Internationalization

This is probably because 6b4b489 changed the model attributes locale file to have separate strings for PuppetclassLookupKey and VariableLookupKey when it should have remained LookupKey (the base class).

> VariableLookupKey.gettext_translation_for_attribute_name :key
"LookupKey|Key"

#2 Updated by The Foreman Bot 12 months ago

  • Status changed from New to Ready For Testing
  • Assigned To set to Daniel Lobato Garcia
  • Pull request https://github.com/theforeman/foreman/pull/4097 added

#3 Updated by Anonymous 12 months ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#4 Updated by Dominic Cleal 12 months ago

  • Release set to 1.14.0

#5 Updated by Daniel Lobato Garcia 11 months ago

  • Target version set to Team Daniel - iteration 6

Also available in: Atom PDF