Bug #18036

Docker repos with disable sync plans causes UI error

Added by Brad Buckingham 9 months ago. Updated 8 months ago.

Status:Closed
Priority:Normal
Assigned To:Partha Aji
Category:Sync Plans
Target version:Team Tom - iteration 10
Difficulty: Pull request:https://github.com/Katello/katello/pull/6576
Bugzilla link:1410939
Story points-
Velocity based estimate-
ReleaseKatello BacklogRelease relationshipAuto

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1410939

1) Create sync plan
2) Disable said sync plan
3) Create new product, set sync plan from step (1) to the product.
4) Try to create docker/yum repository in the product it will fail with error - undefined method `iso8601' for nil:NilClass

I see that an incomplete repo get created in the database, after above error it does not allow to create repo with same name. Under Repositories tab for the product we can not see any repo listed.

This issue is because the sync plan is disabled. "Sync Enabled - No "

Associated revisions

Revision 44e091af
Added by Partha Aji 8 months ago

Fixes #18036 - Correctly sets sync plan schedules

This commit fixes a bug where a disabled sync plan caused an ISE when
a new repository was being created in the product associated to the
sync plan. The issue occured when there was an attempt to calculate the
"next_sync_date" even if the sync plan was disabled.
This commit fixes that issue by making sure that the next sync date
would not get calculated if the plan is disabled.

History

#1 Updated by Brad Buckingham 9 months ago

  • Subject changed from Docker repos with disable sync plans causes UI error to Docker repos with disable sync plans causes UI error
  • Target version set to Team Brad - Iteration 9
  • Release set to Katello Backlog

I have not been able to reproduce this yet; however, expecting to get more input from the bugzilla reporter.

#2 Updated by Partha Aji 9 months ago

  • Assigned To set to Partha Aji
  • Target version changed from Team Brad - Iteration 9 to Team Tom - iteration 9

#3 Updated by Thomas McKay 9 months ago

  • Target version changed from Team Tom - iteration 9 to Team Brad - Iteration 10

#4 Updated by Thomas McKay 9 months ago

  • Target version changed from Team Brad - Iteration 10 to Team Tom - iteration 10

#5 Updated by The Foreman Bot 9 months ago

  • Status changed from New to Ready For Testing
  • Release deleted (Katello Backlog)
  • Pull request https://github.com/Katello/katello/pull/6576 added

#6 Updated by Justin Sherrill 8 months ago

  • Release set to Katello Backlog

#7 Updated by Partha Aji 8 months ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF