Bug #18140

unable to set focus in text field of content host bulk actions errata modal

Added by Thomas McKay 4 months ago. Updated 4 months ago.

Status:Closed
Priority:Normal
Assigned To:Walden Raines
Category:Web UI
Target version:Team Tom - iteration 10
Difficulty: Pull request:https://github.com/Katello/katello/pull/6571
Bugzilla link:
Story points-
Velocity based estimate-
Release3.4.0Release relationshipAuto

Description

The symptom is this: Click in a text area, the cursor is briefly shown, then focus is lost. This prevents editing.

I was able to reproduce on the content-hosts page:
1. click in search field, type a search, hit enter
2. click the bookmarks dropdown next to search field, then click again to dismiss (don't select an entry)
3. click in search field and note above symptom that prevents typing


Related issues

Related to Bastion - Bug #18241: Datepicker and typeahead dropdown menus are not being dis... Closed 01/25/2017
Blocked by Bastion - Feature #18271: Add directive to stop event from propagating Closed 01/26/2017

Associated revisions

Revision a13c53f1
Added by Walden Raines 4 months ago

Fixes #18140: replace search on CH errata modal with filter.

The search on the content host errata modal does not work because of the
requirement of using HostBulkAction.installableErrata() to display the
errata for the selected content hosts. Instead of using search we
should use a filter. Also fix issue with the input not retaining focus
by using the stop event propagation directive workaround.

http://projects.theforeman.org/issues/18140

History

#1 Updated by Walden Raines 4 months ago

  • Status changed from New to Assigned
  • Assigned To set to Walden Raines
  • Target version set to Team Tom - iteration 9

#2 Updated by Walden Raines 4 months ago

  • Subject changed from unable to set focus in text fields to unable to set focus in text field of content host bulk actions errata modal

After https://github.com/Katello/bastion/pull/166 this is only occurring on the bulk actions errata modal as far as I can tell.

#3 Updated by Walden Raines 4 months ago

  • Related to Bug #18241: Datepicker and typeahead dropdown menus are not being displayed added

#4 Updated by Justin Sherrill 4 months ago

  • Release set to 3.4.0

#5 Updated by Walden Raines 4 months ago

  • Blocked by Feature #18271: Add directive to stop event from propagating added

#6 Updated by The Foreman Bot 4 months ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/6571 added

#7 Updated by Thomas McKay 4 months ago

  • Target version changed from Team Tom - iteration 9 to Team Tom - iteration 10

#8 Updated by Walden Raines 4 months ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF