Bug #18188

undefined local variable error when navigating to red hat repositories page

Added by John Mitsch 10 months ago. Updated 9 months ago.

Status:Closed
Priority:Normal
Assigned To:Daniel Lobato Garcia
Category:Web UI
Target version:Foreman - Team Daniel - Iteration 9
Difficulty: Pull request:https://github.com/Katello/katello/pull/6563, https://github.com/Katello/katello/pull/6568
Bugzilla link:
Story points-
Velocity based estimate-
ReleaseKatello 3.4.0Release relationshipAuto

Description

NameError (undefined local variable or method `notification_recipients_path' for #<#<Class:0x007fa0959a5438>:0x007fa0896fc378>):
app/views/home/_user_dropdown.html.erb:2:in `_1daa0c5d310c647763695d7881645383'
app/views/home/_topbar.html.erb:13:in `_ac1318deb28771a69662fccaf38b4c98'
app/views/layouts/base.html.erb:47:in `_c9f61fe9eb7346bd3e49973c75443c4c'
/home/vagrant/katello/app/views/katello/layouts/katello.html.erb:23:in `_dbca9b17ef98f1ab407b6318446f7ab3'
/home/vagrant/katello/app/controllers/katello/providers_controller.rb:13:in `redhat_provider'
app/controllers/concerns/application_shared.rb:14:in `set_timezone'
lib/middleware/catch_json_parse_errors.rb:8:in `call'
lib/middleware/tagged_logging.rb:18:in `call'

To reproduce, navigate to Content > Red Hat Repositories

seems to be related to UI notification changes

https://github.com/Katello/katello/pull/6560 may be related as well


Related issues

Related to Katello - Bug #18166: Use ReactJsHelper on Sync controller Closed 01/19/2017

Associated revisions

Revision 8da4ac05
Added by Daniel Lobato Garcia 10 months ago

Fixes #18188 - Allow notifications in RH repositories

The Red Hat Repositories page is missing the proper helpers to display
notifications. Tt's trying to render the user dropdown (which
makes use of those helpers), but since the needed helpers are not
available, it fails to do so.

History

#1 Updated by John Mitsch 10 months ago

  • Description updated (diff)

#2 Updated by Justin Sherrill 10 months ago

  • Related to Bug #18166: Use ReactJsHelper on Sync controller added

#3 Updated by The Foreman Bot 10 months ago

  • Status changed from New to Ready For Testing
  • Assigned To set to Daniel Lobato Garcia
  • Pull request https://github.com/Katello/katello/pull/6563 added

#4 Updated by Daniel Lobato Garcia 10 months ago

  • Assigned To deleted (Daniel Lobato Garcia)

Current workaround is to use a version of Foreman without the commit https://github.com/theforeman/foreman/commit/1c40f7e8721cdecf098863611c728dcc2a03c464

#5 Updated by The Foreman Bot 10 months ago

  • Assigned To set to Daniel Lobato Garcia

#6 Updated by Anonymous 10 months ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#7 Updated by Daniel Lobato Garcia 10 months ago

  • Target version set to Team Brad - Iteration 11

#8 Updated by The Foreman Bot 10 months ago

  • Pull request https://github.com/Katello/katello/pull/6568 added

#9 Updated by Justin Sherrill 10 months ago

  • Target version deleted (Team Brad - Iteration 11)
  • Release set to Katello 3.4.0

#10 Updated by Daniel Lobato Garcia 9 months ago

  • Target version set to Team Daniel - Iteration 9

Also available in: Atom PDF