Bug #18633

[UX] js error opening "bookmark this search" on subscriptions page

Added by Thomas McKay 3 months ago. Updated 2 months ago.

Status:Closed
Priority:Normal
Assigned To:Walden Raines
Category:-
Target version:Katello - Team Tom - iteration 11
Difficulty: Pull request:https://github.com/Katello/bastion/pull/176
Bugzilla link:
Story points-
Velocity based estimate-

Description

3bastion.js:13551 Error: [$compile:ctreq] Controller 'form', required by directive 'bstFormGroup', can't be found!
http://errors.angularjs.org/1.5.5/$compile/ctreq?p0=form&p1=bstFormGroup
    at bastion.js:69
    at getControllers (bastion.js:9175)
    at nodeLinkFn (bastion.js:9098)
    at bastion.js:9434
    at processQueue (bastion.js:15962)
    at bastion.js:15978
    at Scope.$eval (bastion.js:17230)
    at Scope.$digest (bastion.js:17046)
    at Scope.$apply (bastion.js:17338)
    at done (bastion.js:11573)

To reproduce, attempt to bookmark a search on the subscriptions page

Associated revisions

Revision 301900a0
Added by Walden Raines 2 months ago

Fixes #18633: use ng-form instead of <form> for bookmark.

The bookmark modal needs to use ng-form instead of a <form> element
because it appears within another form. This fixes a JS error about the
controller for form not being found.

http://projects.theforeman.org/issues/18633

History

#1 Updated by Walden Raines 3 months ago

To be clear this happens on every bookmarked search page.

#2 Updated by Walden Raines 2 months ago

  • Project changed from Katello to Bastion
  • Category deleted (Subscriptions)

#3 Updated by The Foreman Bot 2 months ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/bastion/pull/176 added

#4 Updated by Walden Raines 2 months ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF