Bug #19245

Smart-proxy logrotates all files in /var/log/foreman-proxy

Added by Adam Ruzicka 2 months ago. Updated 15 days ago.

Status:Closed
Priority:Normal
Assigned To:Adam Ruzicka
Category:-
Target version:Foreman - Team Ivan Iteration 13
Difficulty: Bugzilla link:1459686
Found in release: Pull request:https://github.com/theforeman/foreman-packaging/pull/1612, https://github.com/theforeman/foreman-packaging/pull/1610
Story points-
Velocity based estimate-

Description

Smart-proxy logrotates files matching the /var/log/foreman-proxy/*.log glob. This may cause issues for processes logging to the same directory which won't be notified about their logs being rotated (smart_proxy_dynflow_core for example). We need to make it logrotate only the files it produces.


Related issues

Related to Packaging - Bug #19521: Smart_proxy_dynflow_core doesn't deploy its logrotate config Closed 05/11/2017

Associated revisions

Revision 1d5c8f1e
Added by adamruzicka 2 months ago

Fixes #19245 - Logrotate specific proxy logs

Revision 2f4d4b82
Added by Adam Ruzicka 2 months ago

Fixes #19245 - Logrotate specific proxy files

History

#1 Updated by Dmitri Dolguikh 2 months ago

  • Category set to Packaging

#2 Updated by Adam Ruzicka 2 months ago

  • Project changed from Smart Proxy to Packaging
  • Category deleted (Packaging)

#3 Updated by Adam Ruzicka 2 months ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman-packaging/pull/1610 added

#4 Updated by Adam Ruzicka 2 months ago

  • Project changed from Packaging to Katello

#5 Updated by Adam Ruzicka 2 months ago

  • Project changed from Katello to Packaging

#6 Updated by Anonymous 2 months ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#7 Updated by The Foreman Bot 2 months ago

  • Pull request https://github.com/theforeman/foreman-packaging/pull/1612 added

#8 Updated by Adam Ruzicka 2 months ago

  • Status changed from Closed to Ready For Testing

Reopening since the DEB PR is not yet merged.

#9 Updated by Adam Ruzicka 2 months ago

  • Status changed from Ready For Testing to Closed

#10 Updated by Ivan Necas 15 days ago

  • Bugzilla link set to 1459686

#11 Updated by Ivan Necas 15 days ago

  • Related to Bug #19521: Smart_proxy_dynflow_core doesn't deploy its logrotate config added

#12 Updated by Ivan Necas 15 days ago

We fixed this issue in smart_proxy_dynflow_core in #19521 and in 1.15, we're not getting

error: tfm-rubygem-smart_proxy_dynflow_core:1 duplicate log entry for /var/log/foreman-proxy/smart_proxy_dynflow_core.log

when running

logrorate /etc/logrotate.conf
.

Therefore, I'm proposing this change to be backported to 1.15.1, as the logorate is not working properly in this combination
and I reverting this in remote execution would introduce the regression, that we tried to fix. It also spams the /var/spool/mail/root every night,
which is something we should keep clean if possible.

Also available in: Atom PDF