Bug #19493

SEQUEL DEPRECATION WARNING: requiring 'sequel/no_core_ext'

Added by Ohad Levy 5 months ago. Updated 5 months ago.

Status:Closed
Priority:Normal
Assigned To:Adam Ruzicka
Category:Dynflow
Target version:Foreman - Team Ivan Iteration 15
Difficulty: Bugzilla link:
Found in release: Pull request:https://github.com/Dynflow/dynflow/pull/232
Story points-
Velocity based estimate-

Description

headsup for deprecation warning on current develop.

SEQUEL DEPRECATION WARNING: requiring 'sequel/no_core_ext' is deprecated and will be removed in Sequel 5.  Just require 'sequel' instead.
/home/foreman/gems/gems/sequel-4.46.0/lib/sequel/no_core_ext.rb:4:in `<top (required)>'
/home/foreman/gems/gems/polyglot-0.3.5/lib/polyglot.rb:65:in `require'
/home/foreman/gems/gems/polyglot-0.3.5/lib/polyglot.rb:65:in `require'
/home/foreman/gems/gems/activesupport-4.2.8/lib/active_support/dependencies.rb:274:in `block in require'
/home/foreman/gems/gems/activesupport-4.2.8/lib/active_support/dependencies.rb:240:in `load_dependency'
/home/foreman/gems/gems/activesupport-4.2.8/lib/active_support/dependencies.rb:274:in `require'
/home/foreman/gems/gems/dynflow-0.8.24/lib/dynflow/persistence_adapters/sequel.rb:1:in `<top (required)>'
/home/foreman/gems/gems/polyglot-0.3.5/lib/polyglot.rb:65:in `require'
/home/foreman/gems/gems/polyglot-0.3.5/lib/polyglot.rb:65:in `require'
/home/foreman/gems/gems/activesupport-4.2.8/lib/active_support/dependencies.rb:274:in `block in require'

History

#1 Updated by Adam Ruzicka 5 months ago

  • Category set to Dynflow
  • Status changed from New to Ready For Testing
  • Assigned To set to Adam Ruzicka
  • Target version set to Team Ivan Iteration 15
  • Pull request https://github.com/Dynflow/dynflow/pull/232 added

#2 Updated by Adam Ruzicka 5 months ago

  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF