Bug #20076

Cant select content view on host group page

Added by Partha Aji 4 months ago. Updated 4 months ago.

Status:Rejected
Priority:Normal
Assigned To:Partha Aji
Category:-
Target version:Team Tom - Iteration 16
Difficulty: Pull request:
Bugzilla link:1463788
Story points-
Velocity based estimate-
ReleaseKatello Recycle BinRelease relationshipAuto

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1463788

Description of problem: Cant select content view on host group page.

Version-Release number of selected component (if applicable): Katello 3.4.0

How reproducible: always

Steps to Reproduce:
1. Create Content view
2. Create host group, select Library
3. Select content view

Actual results: No content views listed

Expected results: List all content views in Library

Additional info: Error in java script console:

```
host_and_hostgroup_edit-5858c30d7573172df3584cf5c792d5990c05d5d46d8541c8f5c56d6fdfd28de1.js:1 Uncaught TypeError: Cannot read property 'registerPluginAttributes' of undefined
at HTMLDocument.<anonymous> (host_and_hostgroup_edit-5858c30d7573172df3584cf5c792d5990c05d5d46d8541c8f5c56d6fdfd28de1.js:1)
at HTMLDocument.dispatch (bundle-24bc1384a85d4a1fb955.js:35)
at HTMLDocument.m.handle (bundle-24bc1384a85d4a1fb955.js:34)
at Object.trigger (bundle-24bc1384a85d4a1fb955.js:35)
at HTMLDocument.<anonymous> (bundle-24bc1384a85d4a1fb955.js:35)
at Function.each (bundle-24bc1384a85d4a1fb955.js:24)
at ce.fn.init.each (bundle-24bc1384a85d4a1fb955.js:24)
at ce.fn.init.trigger (bundle-24bc1384a85d4a1fb955.js:35)
at application-c6b04a2ba9c24fcf301845eb0f6fe153c332128d430190fe7a9881b0f3e24dd9.js:320
at HTMLDocument.<anonymous> (application-c6b04a2ba9c24fcf301845eb0f6fe153c332128d430190fe7a9881b0f3e24dd9.js:13)
```

History

#1 Updated by Partha Aji 4 months ago

  • Subject changed from Cant select content view on host group page to Cant select content view on host group page
  • Target version set to Team Tom - Iteration 16
  • Release set to Katello 3.4.3

#2 Updated by Partha Aji 4 months ago

Need to revert http://projects.theforeman.org/issues/19226 from 3.4 since the related foreman changes didnt make it to 1.15

#3 Updated by Partha Aji 4 months ago

  • Status changed from New to Rejected
  • Release changed from Katello 3.4.3 to Katello Recycle Bin

Sounds like foreman 1.15.1 has to the required commit.. So this commit is fine being in katello 3.4.0.. Rejecting it

Also available in: Atom PDF