Bug #20613

Update the help description for "--sync-date" option in hammer.

Added by Ashish Humbe 5 months ago. Updated 5 months ago.

Status:Closed
Priority:Normal
Assigned To:Ashish Humbe
Category:Hammer
Target version:-
Difficulty:easy Pull request:https://github.com/Katello/hammer-cli-katello/pull/504
Bugzilla link:1481935
Story points-
Velocity based estimate-
ReleaseKatello 3.5.0Release relationshipAuto

Description

Update the help description for "--sync-date" option in hammer.

How reproducible:
Always

Steps to Reproduce:
1. hammer sync-plan create --help
2. Check the help summary of '--sync-date'

start date and time of the synchronization defaults to now                                              
Date and time in YYYY-MM-DD HH:MM:SS or ISO 8601 format

The customer thinks this description is confusing. The customer tried the following command to create sync plan thinking that the --sync-date option is not required as help says "--sync-date will default to now."

hammer --password secret sync-plan create --organization test --name "RedHat Software collections synch" --description "A synch plan for RHSC" --enabled True --interval "weekly" 

It returns:

      Could not create the sync plan:
        Missing arguments for 'sync_date'

Expected:

Change this help with some simple summary? I think the following line in help will be enough.

Provide Date and time in YYYY-MM-DD HH:MM:SS or in ISO 8601 format

Associated revisions

Revision 59ab7402
Added by Ashish Humbe 5 months ago

Fixes #20613 - Update help text for --sync-date (#504)

History

#1 Updated by Kavita Gaikwad 5 months ago

  • Pull request https://github.com/Katello/hammer-cli-katello/pull/504 added

#2 Updated by Tomáš Strachota 5 months ago

  • Project changed from Hammer CLI to Katello
  • Description updated (diff)
  • Category changed from Hammer core to Hammer

Thansk you for reporting the bug. Since the sync-plan command comes from hammer-cli-katello I'm moving it to project Katello, category Hammer where we track issues form that plugin.

#3 Updated by Ashish Humbe 5 months ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

#4 Updated by Eric Helms 5 months ago

  • Release set to Katello 3.5.0

Also available in: Atom PDF