Bug #21132

Incorrect sequence to remove the old katello agent package and certs in bootstrap.py causing error while running yum command

Added by Ashish Humbe 4 months ago. Updated 4 months ago.

Status:Closed
Priority:Normal
Assigned To:Ashish Humbe
Category:Client/Agent
Target version:-
Difficulty:trivial Pull request:https://github.com/Katello/katello-client-bootstrap/pull/224
Bugzilla link:1496473
Story points-
Velocity based estimate-
ReleaseKatello 3.6.0Release relationshipAuto

Description

Description of problem:

Incorrect sequence to remove the old katello agent package and certs causing below error while running yum command:

PYCURL ERROR 77 - "Problem with the SSL CA cert (path? access rights?)" Trying other mirror.

Here is the complete output

  1. /root/bootstrap.py --login=admin --server satellite.example.com --location=Lit="Non-Prod/RHEL6" --activationkey=ak-rhel6-non-prod --force --password=secure
    Foreman Bootstrap Script
    This script is designed to register new systems or to migrate an existing system to a Foreman server with Katello
    [NOTIFICATION], [2017-09-26 09:34:21], [This system is not registered to RHN. Attempting to register via subscription-manager]
    [NOTIFICATION], [2017-09-26 09:34:21], [Removing old Katello agent and certs]
    [SUCCESS], [2017-09-26 09:34:21], [Removing /etc/rhsm/ca/katello-server-ca.pem], completed successfully. <<<<<<<<<<<<<<<<<<<
    [RUNNING], [2017-09-26 09:34:21], [/usr/bin/yum y erase 'katello-ca-consumer*' katello-agent gofer] <<<<<<<<<<<<<<<<<<<
    Loaded plugins: product-id, search-disabled-repos, security, subscription-
    : manager
    Setting up Remove Process
    No Match for argument: katello-agent
    Repo rhel-6-server-rpms forced skip_if_unavailable=True due to: /etc/rhsm/ca/katello-server-ca.pem
    Repo rhel-6-server-rhn-tools-rpms forced skip_if_unavailable=True due to: /etc/rhsm/ca/katello-server-ca.pem
    Repo rhel-6-server-satellite-tools-6.2-rpms forced skip_if_unavailable=True due to: /etc/rhsm/ca/katello-server-ca.pem
    Repo rhel-6-server-extras-rpms forced skip_if_unavailable=True due to: /etc/rhsm/ca/katello-server-ca.pem
    Repo rhel-6-server-optional-rpms forced skip_if_unavailable=True due to: /etc/rhsm/ca/katello-server-ca.pem
    https://satellite.example.com/pulp/repos/example/Library/cv-rhel6-core/content/dist/rhel/server/6/6Server/x86_ 14] PYCURL ERROR 77 - "Problem with the SSL CA cert (path? access rights?)"
    Trying other mirror.
    https://satellite.example.com/pulp/repos/example/Library/cv-rhel6-core/content/dist/rhel/server/6/6Server/x86_no 14] PYCURL ERROR 77 - "Problem with the SSL CA cert (path? access rights?)"
    Trying other mirror.
    https://satellite.example.com/pulp/repos/example/Library/cv-rhel6-core/content/dist/rhel/server/6/6Server/x86_rno 14] PYCURL ERROR 77 - "Problem with the SSL CA cert (path? access rights?)"
    Trying other mirror.
    https://satellite.example.com/pulp/repos/example/Library/cv-rhel6-core/content/dist/rhel/server/6/6Server/x86_CURL ERROR 77 - "Problem with the SSL CA cert (path? access rights?)"
    Trying other mirror.
    https://satellite.example.com/pulp/repos/example/Library/cv-rhel6-core/content/dist/rhel/server/6/6Server/x86_ [Errno 14] PYCURL ERROR 77 - "Problem with the SSL CA cert (path? access rights?)"
    Trying other mirror.
    Package(s) katello-agent available, but not installed.
    No Match for argument: gofer
    Package(s) gofer available, but not installed.
    Resolving Dependencies
    There are unfinished transactions remaining. You might consider running yum-complete-transaction first to finish them.
    --> Running transaction check
    ---> Package katello-ca-consumer-dev-satellite.example.com.noarch 0:1.0-1 will be erased
    --> Finished Dependency Resolution

Dependencies Resolved

================================================================================
Package Arch Version
Repository
Size ================================================================================
Removing:
katello-ca-consumer-dev-satellite.example.com
noarch 1.0-1 installed 14 k

Transaction Summary ================================================================================
Remove 1 Package(s)

Installed size: 14 k
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
Warning: RPMDB altered outside of yum.
Erasing : katello-ca-consumer-dev-satellite.example.com-1. 1/1
https://satellite.example.com/pulcontent/dist/rhel/server/6/6Server/x86_64/optional/os/repodata/productid: [Errno 14] PYCURL ERROR 77 - "Problem with the SSL CA cert (path? access rights?)"
Trying other mirror.
https://satellite.example.com/pulp/repos/example/Library/cv-rhel6-core/content/dist/rhel/server/6/6Server/x86_URL ERROR 77 - "Problem with the SSL CA cert (path? access rights?)"
Trying other mirror.

Verifying  : katello-ca-consumer-dev-satellite.example.com-1.   1/1

Removed:
katello-ca-consumer-dev-satellite.example.com 0:1.0-1

Complete!
[SUCCESS], [2017-09-26 09:34:33], [/usr/bin/yum y erase 'katello-ca-consumer*' katello-agent gofer], completed successfully.

Version-Release number of selected component (if applicable):
Satellite v 6.2 + Bootstrap

How reproducible:
Always

Steps to Reproduce:
1. Try to re-register the (already registed) system to satellite server using bootstrap.py
2.
3.

Actual results:
Fails with below error while removing katello agent packages

Expected results:
The required ssl certificate should be deleted after removing packages so there will not be any error message.

History

#1 Updated by Daniel Lobato Garcia 4 months ago

  • Project changed from Foreman to Katello
  • Category set to Client/Agent

#2 Updated by Ashish Humbe 4 months ago

  • Pull request https://github.com/Katello/katello-client-bootstrap/pull/224 added

#3 Updated by Justin Sherrill 4 months ago

  • Release set to Katello 3.6.0

#4 Updated by Evgeni Golov 4 months ago

  • Status changed from New to Closed

Also available in: Atom PDF