Bug #21506

After upgrade to sat 6.3, running 'foreman-maintain upgrade run' gives error

Added by Kavita Gaikwad 7 months ago. Updated 7 months ago.

Status:Closed
Priority:Normal
Assigned To:Kavita Gaikwad
Category:-
Target version:Foreman - Team Anurag Iteration 22
Difficulty: Bugzilla link:1508353
Found in release: Pull request:https://github.com/theforeman/foreman_maintain/pull/122
Story points-
Velocity based estimate-
Releaseforeman-maintain-0.0.11Release relationshipAuto

Description

There was satellite server which upgraded to sat 6.3 using foreman-maintain.
foreman maintain version: rubygem-foreman_maintain-0.0.10-1.el7sat.noarch

If you run command again -

foreman-maintain upgrade run

Output:
Could not find scenario satellite_6_3_pre_upgrade_check, found 0 scenarios

Associated revisions

Revision d915add0
Added by Kavita Gaikwad 7 months ago

Fixes #21506 - scenario error on upgrade run

History

#1 Updated by Kavita Gaikwad 7 months ago

Kavita Gaikwad wrote:

There is a satellite server which was upgraded to sat 6.3 using foreman-maintain.
foreman maintain version: rubygem-foreman_maintain-0.0.10-1.el7sat.noarch

If you run command again -

foreman-maintain upgrade run

Output:
Could not find scenario satellite_6_3_pre_upgrade_check, found 0 scenarios

After checking logs found that installer command failed with kafo error in /var/log/foreman-installer/satellite.log.

#2 Updated by Kavita Gaikwad 7 months ago

  • Target version set to Team Anurag Iteration 22
  • Assigned To set to Kavita Gaikwad

#3 Updated by Kavita Gaikwad 7 months ago

  • Bugzilla link set to 1508353

#4 Updated by The Foreman Bot 7 months ago

  • Pull request https://github.com/theforeman/foreman_maintain/pull/122 added

#5 Updated by Ivan Necas 7 months ago

  • Status changed from New to Closed

#6 Updated by Ivan Necas 7 months ago

  • Release set to foreman-maintain-0.0.11

Also available in: Atom PDF