Bug #22205

Notifications actions are not correctly set if they are based on blueprint

Added by Marek Hulán 15 days ago. Updated 8 days ago.

Status:Closed
Priority:Normal
Assigned To:Marek Hulán
Category:Notifications
Target version:-
Difficulty: Bugzilla link:
Found in release: Pull request:https://github.com/theforeman/foreman/pull/5159
Story points-
Velocity based estimate-
Release1.17.0Release relationshipAuto

Description

After RSS notification was added, blueprint actions stopped working. The reason is that notification actions defaults to {} and the code that sets default actions from blueprint does ||= which never overrides empty hash. We need to change the condition to if self.actions.blank?

Since this is a regression in 1.17 and easy fix, marking as 1.17 blocker, please reset if you disagree.


Related issues

Related to Foreman - Feature #18292: Add notifications for an RSS feed Closed 01/27/2017

Associated revisions

Revision 099d4ea9
Added by Marek Hulán 8 days ago

Fixes #22205 - restore blueprint actions for notifications

History

#1 Updated by The Foreman Bot 15 days ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/5159 added

#2 Updated by Marek Hulán 15 days ago

#3 Updated by Marek Hulán 8 days ago

  • % Done changed from 0 to 100
  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF