Bug #22502

UI allows quick users to visit new repository page from RH product

Added by Andrew Kofink 4 months ago. Updated 16 days ago.

Status:Closed
Priority:Low
Assigned To:Andrew Kofink
Category:Web UI
Target version:Team Brad - Iteration 27
Difficulty:trivial Pull request:https://github.com/Katello/katello/pull/7360
Bugzilla link: Found in Katello release:
Story points-
Velocity based estimate-
ReleaseKatello 3.6.1Release relationshipAuto

Description

Found in: nightly

Reproduce:
1. Sync Red Hat content (i.e. Satellite Tools)
2. Visit the Red Hat Enterprise Linux Server page
3. Click the 'New Repository' button before it disappears

Actual:
Quick users can click on 'New Repository' and are brought to the new repositories page, but the product ID is blank, so after filling out the form and pressing submit, they are shown the error "Couldn't find Katello::Product with 'id'=".

Expected:
Even quick users can't see any buttons as the page loads. Only after receiving the server response will appropriate buttons be displayed.

Note:
I was unable to reproduce this with custom products.

Associated revisions

Revision 9391c142
Added by Andrew Kofink 16 days ago

Fixes #22502: Wait for product.$resolved b4 using

Don't use buttons that hide/show conditionally on product state without
first checking that the product promise is $resolved.

History

#1 Updated by Justin Sherrill 3 months ago

  • Release set to Katello 3.6.0
  • Target version set to Team Brad - Iteration 27
  • Assigned To set to Jonathon Turel

#2 Updated by John Mitsch about 1 month ago

  • Release changed from Katello 3.6.0 to Katello 3.6.1

#3 Updated by Andrew Kofink 17 days ago

  • Assigned To changed from Jonathon Turel to Andrew Kofink

#4 Updated by The Foreman Bot 16 days ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/7360 added

#5 Updated by Andrew Kofink 16 days ago

  • % Done changed from 0 to 100
  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF