Project

General

Profile

Feature #13089

Support specifying interface MAC address during VM creation

Added by Thomas Rohlik almost 6 years ago. Updated over 5 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Compute resources - libvirt
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Hello,

How?
Create new host and use some MAC in interfaces tab.

What?
After host is created by submit button, host have different (random generated) MAC.

Using Foreman+libvirt provider, without DNS/DHCP.


Related issues

Has duplicate Foreman - Bug #14130: Libvirt image provision generates random MAC address, even though you supply one during provisionDuplicate2016-03-10
Is duplicate of Foreman - Feature #1501: ability to set MAC address of guestsNew

History

#1 Updated by Dominic Cleal almost 6 years ago

  • Tracker changed from Bug to Feature
  • Subject changed from My MAC is overided after host is created to Support specifying interface MAC address during VM creation
  • Category set to Compute resources - libvirt

Currently the compute resource (libvirt) is configured to retrieve and store MAC for Libvirt hosts, the CR service is responsible for generating them.

#2 Updated by Dominic Cleal over 5 years ago

  • Has duplicate Bug #14130: Libvirt image provision generates random MAC address, even though you supply one during provision added

#3 Updated by Ohad Levy over 5 years ago

  • Related to Feature #1501: ability to set MAC address of guests added

#4 Updated by Dominic Cleal over 5 years ago

  • Related to deleted (Feature #1501: ability to set MAC address of guests)

#5 Updated by Dominic Cleal over 5 years ago

  • Is duplicate of Feature #1501: ability to set MAC address of guests added

#6 Updated by Dominic Cleal over 5 years ago

  • Status changed from New to Duplicate

Tracking under existing ticket #1501.

Also available in: Atom PDF