Project

General

Profile

Bug #13514

Uploading results while running 'foreman_scap_client 1' fails on the client

Added by Kedar Bidarkar almost 6 years ago. Updated over 5 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Target version:
-
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Below is the error message thrown when we run "foreman_scap_client 1" on the client.

[xyz@zbc ~]# foreman_scap_client 1
DEBUG: running: oscap xccdf eval --profile xccdf_org.ssgproject.content_profile_common --results-arf /tmp/d20160202-26853-64thh2/results.xml /var/lib/openscap/content/96c2a9d5278d5da905221bbb2dc61d0ace7ee3d97f021fccac994d26296d986d.xml
DEBUG: running: /usr/bin/bzip2 /tmp/d20160202-26853-64thh2/results.xml
Uploading results to https://test.redhat.com:9090/compliance/arf/1
<!DOCTYPE html>
<html>
<head>
<style type="text/css">
body { text-align:center;font-family:helvetica,arial;font-size:22px;
color:#888;margin:20px}
#c {margin:0 auto;width:500px;text-align:left}
</style>
</head>
<body>
<h2>Sinatra doesn’t know this ditty.</h2>
<img src='https://test.redhat.com:9090/compliance/__sinatra__/404.png'>
<div id="c">
Try this:

put '/arf/1' do
  "Hello World" 
end

</div>
</body>
</html>
Upload failed: 404 "Not Found "


Related issues

Related to OpenSCAP - Bug #14621: Uploading results while running 'foreman_scap_client policy_id' fails on the clientClosed2016-04-13

History

#1 Updated by Kedar Bidarkar almost 6 years ago

Wondering if this is because "oscap_proxy" select box turns red when we select an option.

#2 Updated by Marek Hulán almost 6 years ago

  • Status changed from New to Duplicate

Duplicated by http://projects.theforeman.org/issues/14621
The red proxy selector was caused by #14561

#3 Updated by Marek Hulán almost 6 years ago

  • Related to Bug #14621: Uploading results while running 'foreman_scap_client policy_id' fails on the client added

#4 Updated by Dominic Cleal over 5 years ago

  • Project changed from OpenSCAP (top-level) to OpenSCAP
  • Triaged set to Yes

Also available in: Atom PDF