Project

General

Profile

Bug #14598

hammer help text shows HTML characters such as "'"

Added by Bryan Kearney almost 5 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:
In Kanboard:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1325525
Description of problem:

Several hammer cli commands and subcommands show HTML characters in their help text. For example:

repository list --help

Usage:
hammer repository list [OPTIONS]

Options:
--available-for AVAILABLE_FOR interpret specified object to return only Repositories that can be
associated with specified object. Only 'content_view' is
supported.

The string 'Only 'content_view' is' should be rendered as 'Only "content_view" is'.

At a first glance, it looks like we're converting quote characters into HTML.

Version-Release number of selected component (if applicable):

  • Satellite 6.2.0 SNAP 7.1

How reproducible:

Steps to Reproduce:
1. Run the "hammer repository list -h" command (other commands/subcommands will also work)
2.
3.

Actual results:

Expected results:

Additional info:


Related issues

Related to Hammer CLI - Refactor #15198: Remove change to Apipie option definition.New

Associated revisions

Revision 17e9b68f (diff)
Added by Zach Huntington-Meath over 4 years ago

Fixes #14598 - Descriptions from Apipie will not contain unescaped HTML

History

#1 Updated by The Foreman Bot over 4 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/hammer-cli/pull/205 added

#2 Updated by Dominic Cleal over 4 years ago

  • Related to Refactor #15198: Remove change to Apipie option definition. added

#3 Updated by Zach Huntington-Meath over 4 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF