Project

General

Profile

Bug #15140

Input for editing settings too small

Added by Ondřej Pražák over 4 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Settings
Target version:
Difficulty:
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

The text field for editing settings shrinks after unsuccessful edit.

Steps to reproduce:
1) go to settings
2) choose a setting and try to save with invalid value (per_page: "test"), it resets to initial value and hides the in-place form
3) try to edit the same setting again
4) see that input field is now very small

in-place-setting.png View in-place-setting.png 9.08 KB Ondřej Pražák, 05/23/2016 09:03 AM
In place setting

Associated revisions

Revision 33244e52 (diff)
Added by Amir Fefer over 4 years ago

Fixes #15140 - Correctly handle failed setting change

The jEditable library contains a bug that causes any failed changes to
settings to break the layout of the setting input in following changes.
Since the library is not maintained any more, we had to change our copy
of the library to fix the bug. This is an intermidiate fix until we
replace jeditable with a better, maintained solution.

Revision 5816b6e9 (diff)
Added by Amir Fefer over 4 years ago

Fixes #15140 - Correctly handle failed setting change

The jEditable library contains a bug that causes any failed changes to
settings to break the layout of the setting input in following changes.
Since the library is not maintained any more, we had to change our copy
of the library to fix the bug. This is an intermidiate fix until we
replace jeditable with a better, maintained solution.

(cherry picked from commit 33244e524910f9a84434850a9ed81037fd29c13a)

History

#1 Updated by Dominic Cleal over 4 years ago

  • Category changed from Web Interface to Settings

#2 Updated by Amir Fefer over 4 years ago

  • Assignee set to Amir Fefer

#3 Updated by Dominic Cleal over 4 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/3569 added

#4 Updated by Amir Fefer over 4 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#5 Updated by Dominic Cleal over 4 years ago

  • Legacy Backlogs Release (now unused) set to 161

Also available in: Atom PDF