Project

General

Profile

Bug #15721

Helper rake tasks not fully updated for Host Unification and Scoped search

Added by Justin Sherrill almost 3 years ago. Updated 10 months ago.

Status:
Closed
Priority:
Normal
Category:
Hosts
Target version:
Difficulty:
medium
Triaged:
Yes
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

these two rake tasks:

rake katello:reindex
rake katello:clean_backend_objects

have not been fully updated to support host unification and scoped search.

Also, the katello db is now the canonical source for information about hosts, no reindex on them needed


Related issues

Related to Katello - Bug #15602: cannot delete or unregister a host if it no longer exists in candlepinResolved2016-07-07
Is duplicate of Katello - Bug #15908: unable to clear host from Katello via rake tasks after host is deleted in candlepinDuplicate2016-07-29

Associated revisions

Revision 5f624ad3 (diff)
Added by Justin Sherrill almost 3 years ago

Fixes #15721 - adapt rake tasks for host_uni and scoped search (#6192)

History

#1 Updated by The Foreman Bot almost 3 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/6192 added

#2 Updated by Justin Sherrill almost 3 years ago

  • Bugzilla link set to 1357866

#3 Updated by Justin Sherrill almost 3 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#4 Updated by Justin Sherrill almost 3 years ago

  • Legacy Backlogs Release (now unused) set to 171

#5 Updated by Justin Sherrill almost 3 years ago

  • Is duplicate of Bug #15908: unable to clear host from Katello via rake tasks after host is deleted in candlepin added

#6 Updated by Justin Sherrill over 2 years ago

  • Related to Bug #15602: cannot delete or unregister a host if it no longer exists in candlepin added

#7 Updated by Eric Helms over 2 years ago

  • Legacy Backlogs Release (now unused) changed from 171 to 162

Also available in: Atom PDF