Project

General

Profile

Bug #15941

Content dashboard has wrong links to [Invalid|Insufficient|Current] Subscriptions

Added by Zach Huntington-Meath almost 3 years ago. Updated 11 months ago.

Status:
Closed
Priority:
Normal
Category:
Dashboard
Target version:
Difficulty:
easy
Triaged:
Yes
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1180573
Description of problem:
In katello dashboard, subscription widget provides links to lists of content hosts with [Invalid|Insufficient|Current] Subscriptions. Those links are wrong, as they apply on content host filters "status:red" instead of "status=red". Such filter is ignored on content host and the result shows all content hosts.

Version-Release number of selected component (if applicable):
Sat 6.0.6

How reproducible:
100%

Steps to Reproduce:
1. In WebUI, open Content Dashboard (https://satellite.example.com/katello/dashboard#!=)
2. See "Invalid Subscriptions" is 0 in subscription widget.
3. Click to the "Invalid Subscriptions" link

Actual results:
URL https://satellite.example.com/content_hosts?search=status:red is loaded. I.e. content_hosts with applied filter "status:red".

All content hosts are displayed.

Expected results:
Proper URL is loaded under content_hosts, with applied filter "status=red".

No content host is displayed (assuming "Invalid Subscriptions" was really 0).

Additional info:
Can't be search=status%3Dred used? (%3D is encoding of '=') It works for me well as direct URL.

Associated revisions

Revision 73cc4243 (diff)
Added by Zach Huntington-Meath almost 3 years ago

Fixes #15941: Content-host subscription dashboard is linked. (#6222)

Fixed up and made the code a lot more intelligable.

History

#1 Updated by Zach Huntington-Meath almost 3 years ago

  • Assignee set to Zach Huntington-Meath

#2 Updated by The Foreman Bot almost 3 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/6222 added

#3 Updated by Zach Huntington-Meath almost 3 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#4 Updated by Justin Sherrill almost 3 years ago

  • Legacy Backlogs Release (now unused) set to 162
  • Difficulty set to easy

Also available in: Atom PDF