Project

General

Profile

Bug #6530

Specifying only proxy-url and proxy-port during install leads to errors during installation

Added by Eric Helms almost 7 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Installer
Target version:
Difficulty:
trivial
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1117410
Description of problem:

Version-Release number of selected component (if applicable):
Satellite 6.0.3

How reproducible:

Setup: Internal network, only http(s)-Proxy allowed, Fresh install, Satellite 6 Beta prerequisites met.
  1. katello-installer --katello-proxy-url=http://myproxy --katello-proxy-port=8080

1. Content -> Red Hat Subscriptions -> Import manifest ...
2. Content -> Red Hat Repositories -> (random repo, I tried "Red Hat Enterprise Linux 6 Server (RPMs)")
> Endless turning wheel

3. Reloading the Red Hat Repositories site shows me that repository marked for sync.

4. Checking sync status: Content -> Sync status actually shows me the HTTP 500 Error.
Log file:
> /var/log/httpd/foreman-ssl_error_ssl.log <==
[Mon Jul 07 19:05:50 2014] [error] [client 172.23.8.1] mod_wsgi (pid=6885): Exception occurred processing WSGI script '/srv/pulp/webservices.wsgi'.
[Mon Jul 07 19:05:50 2014] [error] [client 172.23.8.1] TypeError: 'NoneType' object is not callable

> /var/log/httpd/foreman-ssl_access_ssl.log <
172.23.8.1 - - [07/Jul/2014:19:05:50 +0200] "POST /pulp/api/v2/repositories/search/ HTTP/1.1" 500 343 "-" "Ruby"
212.0.27.18 - - [07/Jul/2014:19:05:50 +0200] "GET /katello/sync_management HTTP/1.1" 500 441 "https://$HOSTNAME/katello/providers/redhat_provider" "Mozilla/5.0 (Windows NT 6.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/35.0.1916.153 Safari/537.36"

Actual results:
Under Administer -> Content Notices you see a HTTP 500 Error.

Expected results:
no error

Associated revisions

Revision b57e9250 (diff)
Added by Eric Helms almost 7 years ago

Fixes #6530: Ensure proxy configs work if not all values specified.

If only host or port were specified, a trailing coma resulted in the
configs causing Pulp to fail to start since the JSON was considered
invalid.

Revision c9e760fc
Added by Eric Helms almost 7 years ago

Merge pull request #21 from ehelms/fixes-6530

Fixes #6530: Ensure proxy configs work if not all values specified.

Revision 7e1e61f2 (diff)
Added by Eric Helms almost 7 years ago

Refs #6530: Ensure null for proxy_port if not defined.

Revision df6e3f2f
Added by Eric Helms almost 7 years ago

Merge pull request #22 from ehelms/refs-6530

Refs #6530: Ensure null for proxy_port if not defined.

Revision 75be7cc6 (diff)
Added by Eric Helms almost 7 years ago

Fixes #6530: Update proxy configurations for Pulp.

Revision a789ae2b
Added by Eric Helms almost 7 years ago

Merge pull request #84 from ehelms/fixes-6530

Fixes #6530: Update proxy configurations for Pulp.

History

#1 Updated by Eric Helms almost 7 years ago

  • Status changed from New to Assigned
  • Target version set to 49
  • Legacy Backlogs Release (now unused) set to 13
  • Difficulty set to trivial
  • Triaged changed from No to Yes

#2 Updated by Eric Helms almost 7 years ago

  • Pull request https://github.com/Katello/katello-installer/pull/84 added

#3 Updated by Eric Helms almost 7 years ago

  • Status changed from Assigned to Ready For Testing

#4 Updated by Eric Helms almost 7 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF