Project

General

Profile

Bug #8023

katello-installer fails if files with a .pp extension are found in the working directory that katello-installer is invoked from.

Added by Dominic Cleal almost 6 years ago. Updated almost 6 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1154170
Description of problem:

katello-installer fails if files with a .pp extension are found in the working directory that katello-installer is invoked from.

Version-Release number of selected component (if applicable):
katello-installer-0.0.64-1.el6sat.noarch

How reproducible:
100%

Steps to Reproduce:
[root@satellite ~]# cd ~
[root@satellite ~]# echo foobar > baz.pp
[root@satellite ~]# katello-installer --help

Actual results:

/usr/lib/ruby/site_ruby/1.8/puppet/parser/parser_support.rb:157:in `on_error': Could not parse for environment production: Syntax error at end of file at /root/baz.pp:2 (Puppet::Error)
from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `_racc_yyparse_c'
from /usr/lib/ruby/site_ruby/1.8/puppet/parser/lexer.rb:522:in `scan'
from /usr/lib/ruby/1.8/racc/parser.rb:152:in `_racc_yyparse_c'
from /usr/lib/ruby/1.8/racc/parser.rb:152:in `__send__'
from /usr/lib/ruby/1.8/racc/parser.rb:152:in `yyparse'
from /usr/lib/ruby/site_ruby/1.8/puppet/parser/parser_support.rb:168:in `parse'
from /usr/lib/ruby/site_ruby/1.8/puppet/node/environment.rb:536:in `perform_initial_import'
from /usr/lib/ruby/site_ruby/1.8/puppet/node/environment.rb:534:in `map'
from /usr/lib/ruby/site_ruby/1.8/puppet/node/environment.rb:534:in `perform_initial_import'
from /usr/lib/ruby/site_ruby/1.8/puppet/node/environment.rb:255:in `known_resource_types'
from /usr/lib/ruby/site_ruby/1.8/puppet/resource/type_collection_helper.rb:5:in `known_resource_types'
from /usr/lib/ruby/site_ruby/1.8/puppet/parser/parser_support.rb:120:in `import'
from /usr/lib/ruby/gems/1.8/gems/kafo_parsers-0.0.3/lib/kafo_parsers/puppet_module_parser.rb:38:in `initialize'
from /usr/lib/ruby/gems/1.8/gems/kafo_parsers-0.0.3/lib/kafo_parsers/puppet_module_parser.rb:16:in `new'
from /usr/lib/ruby/gems/1.8/gems/kafo_parsers-0.0.3/lib/kafo_parsers/puppet_module_parser.rb:16:in `parse'
from /usr/lib/ruby/gems/1.8/gems/kafo-0.6.4/lib/kafo/puppet_module.rb:44:in `parse'
from /usr/lib/ruby/gems/1.8/gems/kafo-0.6.4/lib/kafo/configuration.rb:84:in `modules'
from /usr/lib/ruby/gems/1.8/gems/kafo-0.6.4/lib/kafo/configuration.rb:84:in `map'
from /usr/lib/ruby/gems/1.8/gems/kafo-0.6.4/lib/kafo/configuration.rb:84:in `modules'
from /usr/lib/ruby/gems/1.8/gems/kafo-0.6.4/lib/kafo/kafo_configure.rb:170:in `modules'
from /usr/lib/ruby/gems/1.8/gems/kafo-0.6.4/lib/kafo/kafo_configure.rb:152:in `params'
from /usr/lib/ruby/gems/1.8/gems/kafo-0.6.4/lib/kafo/kafo_configure.rb:185:in `set_parameters'
from /usr/lib/ruby/gems/1.8/gems/kafo-0.6.4/lib/kafo/kafo_configure.rb:66:in `initialize'
from /usr/lib/ruby/gems/1.8/gems/clamp-0.6.2/lib/clamp/command.rb:125:in `new'
from /usr/lib/ruby/gems/1.8/gems/clamp-0.6.2/lib/clamp/command.rb:125:in `run'
from /usr/lib/ruby/gems/1.8/gems/kafo-0.6.4/lib/kafo/kafo_configure.rb:116:in `run'
from /usr/sbin/katello-installer:9

Expected results:
katello-installer runs normally & without error.

Additional info:
.pp files are commonly used for SELinux policy files. In this usage, the end-user had a file in their homedir, which exposed this error.


Related issues

Is duplicate of Kafo - Bug #7288: Unable to run the installer when SELinux policy is present in the current directoryResolved2014-08-28

History

#1 Updated by Marek Hulán almost 6 years ago

  • Is duplicate of Bug #7288: Unable to run the installer when SELinux policy is present in the current directory added

#2 Updated by Dominic Cleal almost 6 years ago

  • Status changed from New to Duplicate

Also available in: Atom PDF