Project

General

Profile

Bug #8425

n+1 query on audits index

Added by Daniel Lobato Garcia over 7 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
Normal
Category:
Database
Target version:
Difficulty:
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Audits include users who performed actions, and these are being called on n+1 queries. Fix should be as simple as providing the users through the controller.


Related issues

Related to Foreman - Bug #8442: Eager loading on audits page does not workClosed2014-11-18
Is duplicate of Foreman - Bug #8419: n+1 query in audits indexDuplicate2014-11-17

Associated revisions

Revision a2fc4fbe (diff)
Added by Daniel Lobato Garcia over 7 years ago

Fixes #8425 - n+1 query on audits index

Audits index include users who performed actions, and these are being
called with n+1 queries. Fix should be as simple as providing the
users through the controller with an includes.

History

#1 Updated by The Foreman Bot over 7 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/1951 added
  • Pull request deleted ()

#2 Updated by Ori Rabin over 7 years ago

  • Is duplicate of Bug #8419: n+1 query in audits index added

#3 Updated by Ori Rabin over 7 years ago

  • Status changed from Ready For Testing to Duplicate

#4 Updated by Dominic Cleal over 7 years ago

  • Category set to Database
  • Status changed from Duplicate to Ready For Testing
  • Assignee set to Daniel Lobato Garcia

#5 Updated by Dominic Cleal over 7 years ago

  • Legacy Backlogs Release (now unused) set to 21

#6 Updated by Daniel Lobato Garcia over 7 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#7 Updated by Ohad Levy over 7 years ago

  • Related to Bug #8442: Eager loading on audits page does not work added

#8 Updated by Dominic Cleal over 7 years ago

  • Legacy Backlogs Release (now unused) changed from 21 to 28

Also available in: Atom PDF