Project

General

Profile

Statistics
| Branch: | Tag: | Revision:

runcible / lib / runcible / extensions @ bf01400f

Name Size
consumer.rb 7.18 KB
consumer_group.rb 4.02 KB
deb.rb 620 Bytes
deb_component.rb 657 Bytes
deb_release.rb 647 Bytes
distribution.rb 167 Bytes
docker_image.rb 166 Bytes
docker_manifest.rb 172 Bytes
docker_manifest_list.rb 181 Bytes
docker_tag.rb 162 Bytes
errata.rb 156 Bytes
file.rb 150 Bytes
ostree_branch.rb 161 Bytes
package_category.rb 174 Bytes
package_group.rb 168 Bytes
puppet_module.rb 168 Bytes
python_package.rb 170 Bytes
repository.rb 19.4 KB
rpm.rb 620 Bytes
srpm.rb 622 Bytes
unit.rb 5.24 KB
yum_repo_metadata_file.rb 184 Bytes

Latest revisions

# Date Author Comment
bf01400f 11/10/2017 02:13 PM Matthias Dellweg

refs #10478 - Add deb extensions

0b79887a 10/13/2017 06:02 PM Justin Sherrill

Srpm support

c2292684 10/06/2017 06:35 PM Partha Aji

Fixes #21161 - Docker manifest list model bindings

1a2d49fd 09/07/2016 12:46 PM Justin Sherrill

Fixes #16466 - Add support for applicable rpms

1f392e3e 07/20/2016 10:09 PM Eric D Helms

Fixes #15617: Add ISO repository support (#179)

5126dd02 05/12/2016 07:59 PM David Davis

Fixes #15016 - Upgrade rubocop (#177)

61c9e238 03/04/2016 08:15 PM Partha Aji

Fixes #14032 - Ostree branches now searchable in a Repo

ddfc4136 02/03/2016 11:51 PM Partha Aji

Fixes #13284 - Enables Taskgroups for Applicablity

The regenerate applicable errata call for a repository can return
either a Task Group or a list of spawned tasks. This commit enables
the use of that.
This is an important change in pulp 2.8.
Look at
https://github.com/pulp/pulp/blob/master/docs/dev-guide/integration/rest-api/consumer/applicability.rst#generate-content-applicability-for-updated-repositories...

e747b1ce 02/02/2016 01:38 AM Brad Buckingham

fixes #13512 - docker v2 - pulp 2.8 - add support for tag content unit

With the pulp 2.8 support for docker v2, the docker tag implementation
has been updated to be a content type, similar to manifest, rpm...etc.
This commit adds that unit.

cf78605e 01/29/2016 11:42 AM Brad Buckingham

fixes #13460 - docker v2 - disable v1 support & introduce docker_manifest unit type

This commit makes 2 changes:
1. update the docker importer to support the 'enable_v1' flag
2. introduce the docker_manifest unit which is being added with
docker v2

View revisions

Also available in: Atom