Bug #12074

rack-cache 1.3.0 is incompatible with Ruby 1.9.3

Added by Eric Helms over 2 years ago. Updated over 2 years ago.

Status:Closed
Priority:Normal
Assigned To:Eric Helms
Category:Packaging
Target version:-
Difficulty: Bugzilla link:
Found in release: Pull request:https://github.com/theforeman/foreman/pull/2786
Story points-
Velocity based estimate-
Release1.9.3Release relationshipAuto

Description

During bundle install:

Installing rack-cache 1.3.0

Gem::InstallError: rack-cache requires Ruby version >= 2.0.0.

Related issues

Related to Foreman - Refactor #8884: Drop Ruby 1.9.3 support Closed 01/09/2015

Associated revisions

Revision 3b3f0a11
Added by Eric Helms over 2 years ago

Fixes #12074: Pin rack-cache to less than 1.3.0

The 1.3.0 version of rack-cache requires Ruby 2.0 or greater.

Revision 9399b0a6
Added by Eric Helms over 2 years ago

Fixes #12074: Pin rack-cache to less than 1.3.0

The 1.3.0 version of rack-cache requires Ruby 2.0 or greater.

(cherry picked from commit 3b3f0a118c9ec860abf52b454e8d70c9132e8948)

Revision 24436512
Added by Eric Helms over 2 years ago

Fixes #12074: Pin rack-cache to less than 1.3.0

The 1.3.0 version of rack-cache requires Ruby 2.0 or greater.

(cherry picked from commit 3b3f0a118c9ec860abf52b454e8d70c9132e8948)

History

#1 Updated by The Foreman Bot over 2 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/2786 added

#2 Updated by Michael Moll over 2 years ago

#3 Updated by Dominic Cleal over 2 years ago

  • Category set to Packaging
  • Assigned To set to Eric Helms
  • Release set to 1.9.3

#4 Updated by Eric Helms over 2 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF