Bug #12111

Table or column widths

Added by Jeff Sparrow over 1 year ago. Updated 9 months ago.

Status:Closed
Priority:Normal
Assigned To:Tomer Brisker
Category:Web Interface
Target version:Team Daniel - iteration 3
Difficulty: Bugzilla link:
Found in release: Pull request:https://github.com/theforeman/foreman/pull/3884
Story points-
Velocity based estimate-
Release1.13.1Release relationshipAuto

Description

Spoke briefly with tbrisker in #theforeman, he said to create this.

I am looking at wanting to edit the size of the table or columns in foreman.

Issue 1. is related to the extra column plugin - https://github.com/GregSutcliffe/foreman_column_view - It doesnt truncate long facts, and ends up stretching the width of the column, which then stretches the width of the entire table and makes other columns look strange. Unfortunately I lost my example, but it would be easy to reproduce by setting the fact in the plugin to something like path (or anything that is lengthy)

Issue 2. when creating a longer environment name, it truncates it too much. I know, I know, these two issues kind of conflict. But the issue is, the main env we use is production. Then there is production_something, production_something_else, production_something_etc. Every one of these environments show up as production_ so it is nearly impossible, without pausing the mouse on the environment of each server, to tell what environment its actually in.

A way to change column or table width would be helpful. Mainly table width, because there is so much unused whitespace on the left and right ;)


Related issues

Related to Foreman - Bug #8800: Table cells should clip with tooltip only if text actuall... Closed 12/28/2014
Related to Foreman - Feature #1403: [foreman] [UI] - tables columns should be resizable New 12/19/2011

Associated revisions

Revision 7fe3001e
Added by Tomer Brisker 9 months ago

Fixes #12111 - Set width for host list action column

This makes no siginificant change to core but allows unbreaking
foreman_column_view plugin.

History

#1 Updated by Dominic Cleal over 1 year ago

We may be able to add this information to #1403 and/or #2937.

#2 Updated by Jeff Sparrow over 1 year ago

Dominic Cleal wrote:

We may be able to add this information to #1403 and/or #2937.

Looks like it huh? Not sure about Issue 1 though, as I havent looked in to how the plugin actually inputs the fact info. If the table features are added to foreman, a question would be if those would also control that plugins information. Right now its only the data from that plugin that doesnt get truncated, all other columns do, just fyi.

#3 Updated by Tomer Brisker over 1 year ago

  • Related to Bug #8800: Table cells should clip with tooltip only if text actually overflows added

#4 Updated by Tomer Brisker over 1 year ago

Hi Jeff,
Thank you for you input.
I'll start with point no. 2 - #8800 has just been merged into nightly, which should improve the situation a bit by only clipping cells that need clipping. Once Patternfly (#4629) gets merged this will improve even more as the base content width will be increased to 1400px.
As to issue no. 1 - since #8800 has been merged, the plugin can and should use its ability to ellipsize overflowing text. I will look into creating a patch to the plugin to fix this.
As a side note, I am looking into possibly including a JS plugin that will allow users to dynamically control column sizes, which will hopefully solve this kind of issues for good.

#5 Updated by Jeff Sparrow over 1 year ago

Thanks for the update. The plan sounds good, cant wait to try it out!

#6 Updated by Tomer Brisker over 1 year ago

  • Related to Feature #1403: [foreman] [UI] - tables columns should be resizable added

#7 Updated by Tomer Brisker over 1 year ago

  • Tracker changed from Support to Bug
  • Project changed from Foreman to Plugins
  • Category deleted (Web Interface)
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/GregSutcliffe/foreman_column_view/pull/18 added

Hi,
I have submitted a PR to address issue #1 and converted this issue to the bug report for it.
Issue #2 should be fixed for 1.11 as mentioned above. (seems like the fix was too late to make the cut for 1.10)
As for dynamically resizing columns, this requires a bit of work and will be tracked in #1403.

#8 Updated by Tomer Brisker 9 months ago

  • Project changed from Plugins to Foreman
  • Category set to Web Interface
  • Pull request deleted (https://github.com/GregSutcliffe/foreman_column_view/pull/18)

Looks like this will need a minor change to core to get working, moving back to Foreman core for that fix to be picked up.

#9 Updated by The Foreman Bot 9 months ago

  • Pull request https://github.com/theforeman/foreman/pull/3884 added

#10 Updated by Anonymous 9 months ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#11 Updated by Dominic Cleal 9 months ago

  • Release set to 1.13.1

#12 Updated by Daniel Lobato Garcia 9 months ago

  • Target version set to Team Daniel - iteration 3

Also available in: Atom PDF