Bug #14336

Incremental update using cli does not update systems when --update-all-systems=true is passed

Added by Justin Sherrill about 2 years ago. Updated about 2 years ago.

Status:Closed
Priority:Normal
Assigned To:Justin Sherrill
Category:Errata Management
Target version:-
Difficulty:hard Pull request:https://github.com/Katello/katello/pull/5916, https://github.com/Katello/hammer-cli-katello/pull/371
Bugzilla link:1315278 Found in Katello release:
Story points-
Velocity based estimate-
ReleaseKatello 3.0.0Release relationshipAuto

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1315278
++ This bug was initially created as a clone of Bug #1304886 ++

Description of problem:
Incremental update using cli does not update systems when --update-all-systems=true is passed

Version-Release number of selected component (if applicable):
Sat 6.1.6

How reproducible:
Always

Steps to Reproduce:
hammer > content-view version incremental-update --content-view-version-id=4 --errata-ids=a8e3bdf7-b147-4922-87fa-771ea0cc2ea3 --environment-ids=2 --update-all-systems=true

Actual results:
The incremental update finished but the systems are not updated

Expected results:
The incremental update finished but the systems are updated

Additional info:

--- Additional comment from RHEL Product and Program Management on 2016-02-04 17:02:18 EST ---

This bug report has Keywords: Regression or TestBlocker.

Since no regressions or test blockers are allowed between releases,
it is also being identified as a blocker for this release.

Please resolve ASAP.

--- Additional comment from RHEL Product and Program Management on 2016-02-04 17:13:29 EST ---

Since this issue was entered in Red Hat Bugzilla, the pm_ack has been
set to + automatically for the next planned release

--- Additional comment from Sureshkumar Thirugnanasambandan on 2016-02-04 17:30:27 EST ---

There are no errors shown at all. It looks like --update-all-systems=true is silently ignored.

--- Additional comment from RHEL Product and Program Management on 2016-02-17 16:12:10 EST ---

This bug report previously had all acks and release flag approved.
However since at least one of its acks has been changed, the
release flag has been reset to ? by the bugbot (pm-rhel). The
ack needs to become approved before the release flag can become
approved again.


Related issues

Related to Katello - Bug #13254: support rpm and errata ids as part of incremental update Closed 01/16/2016
Duplicated by Katello - Bug #16180: Incremental update using cli does not update systems when... Duplicate 08/18/2016

Associated revisions

Revision d826df47
Added by Justin Sherrill about 2 years ago

Fixes #14336,#13254 - bug fixes and improvements for incremental update

This commit does a few things:

  • Converts the incremental update api to reference only hosts
  • Adds the ability to specify uuid or id for packages
  • Adds the ability to specify uuid, id, or errata id for errata
  • Removes the 'update_all_systems' parameters, as you can just pass in an
    empty search string to accomplish the same function
  • Does not create dynflow subtask for non-applicable hosts
  • Converts the errata apply UI to be host based
  • Adds installable_errata to the things you can search hosts for
    (needed for above)

Revision 82a7eb99
Added by Justin Sherrill about 2 years ago

Merge pull request #5916 from jlsherrill/inc_update

Fixes #14336,#13254 - bug fixes and improvements for incremental update

Revision 15f8cfda
Added by Justin Sherrill about 2 years ago

Refs #14336 - fixes update-all-hosts for inc update

Revision 5025974b
Added by Justin Sherrill about 2 years ago

Merge pull request #371 from jlsherrill/14336

Refs #14336 - fixes update-all-hosts for inc update

History

#1 Updated by Eric Helms about 2 years ago

  • Related to Bug #13254: support rpm and errata ids as part of incremental update added

#2 Updated by Justin Sherrill about 2 years ago

  • Release set to Katello 3.0.0
  • Difficulty set to hard

#3 Updated by The Foreman Bot about 2 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/5916 added

#4 Updated by The Foreman Bot about 2 years ago

  • Pull request https://github.com/Katello/hammer-cli-katello/pull/371 added

#5 Updated by Justin Sherrill about 2 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#6 Updated by Justin Sherrill over 1 year ago

  • Duplicated by Bug #16180: Incremental update using cli does not update systems when --update-all-systems=true is passed added

Also available in: Atom PDF