Bug #14951

Can not submit when provisioning a discovered host with parameter override

Added by Or Tal 11 months ago. Updated 4 months ago.

Status:Closed
Priority:Normal
Assigned To:Ori Rabin
Category:Smart Variables
Target version:Team Ivan Iteration 6
Difficulty: Bugzilla link:
Found in release: Pull request:https://github.com/theforeman/foreman/pull/4023
Story points-
Velocity based estimate-
Release1.13.2Release relationshipAuto

Description

steps to reproduce:
- provision a NEW discovered host
- override a class parameter (creates an FDQN override?)
- submit

I get the same screen again. production.log shows:
"Failed to save: Match fqdn=st-nj05-grid17.striketechnologies.com does not match an existing host"

setting.yaml :unattended:true

workaround:
remove the override, submit the new host, edit it, add the override.


Related issues

Related to Discovery - Refactor #14035: Redesign discovered host New 03/03/2016

Associated revisions

Revision 11617115
Added by Ori Rabin 4 months ago

Fixes #14951 - Allow matcher for host turning into managed host

History

#1 Updated by Or Tal 11 months ago

foreman 1.11.0

#2 Updated by Tomer Brisker 11 months ago

  • Status changed from New to Assigned
  • Assigned To set to Ori Rabin

#3 Updated by Dominic Cleal 11 months ago

  • Category set to Smart Variables

#4 Updated by Ori Rabin 11 months ago

  • Project changed from Foreman to Discovery
  • Category deleted (Smart Variables)

#5 Updated by Ori Rabin 11 months ago

#6 Updated by Ori Rabin 4 months ago

  • Project changed from Discovery to Foreman
  • Target version set to Team Ivan Iteration 6

Moving this to core because even if this currently only affects discovery it is a result of allowing matchers on hosts only when editing a managed host or creating a new one and does not consider changing a host's type to managed.

#7 Updated by The Foreman Bot 4 months ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/4023 added

#8 Updated by Ori Rabin 4 months ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#9 Updated by Dominic Cleal 4 months ago

  • Category set to Smart Variables
  • Release set to 1.13.2

Also available in: Atom PDF