Bug #1644

Changing VNC keymap on a Libvirt VM (via virt-manager or virsh) causes web-based console to choke

Added by Andreas Ntaflos over 5 years ago. Updated 5 months ago.

Status:Closed
Priority:Normal
Assigned To:Michael Moll
Category:Compute resources - libvirt
Target version:-
Difficulty: Bugzilla link:
Found in release: Pull request:https://github.com/theforeman/foreman/pull/4784
Story points-
Velocity based estimate-
Release1.16.0Release relationshipAuto

Description

The web-based console of a host provisioned as a (Libvirt) VM cannot be used when the VNC keymap of the VM has been changed from "auto" to something else (by means of virt-manager or virsh). Clicking on "Console" fails with this error message:

Failed to set console: Call to virDomainUpdateDeviceFlags failed: internal error cannot change keymap setting on vnc graphics

The same message is visible in the Libvirt host's logs:

2012-05-19 20:59:36.339+0000: 26184: error : qemuDomainChangeGraphics:1357 : internal error cannot change keymap setting on vnc graphics

Using Ubuntu 12.04, Libvirt 0.9.8 and Foreman 0.5-nightly-ba71c565.


Related issues

Related to Foreman - Bug #1739: Keymap is incorrect in VNC New 07/10/2012
Related to Foreman - Bug #19692: Opening a libvirt VM console fails with fog-libvirt 0.4.0 Closed 05/26/2017
Blocked by Foreman - Refactor #19579: require fog-libvirt 0.4.0 Closed 05/17/2017

Associated revisions

Revision 9b960ab6
Added by Michael Moll 5 months ago

Fixes #1644,#19692 - update fog-libvirt to 0.4.1

History

#1 Updated by Joshua Hoblitt about 5 years ago

I suspect #1739 is either related to or a duplicate of this bug.

#2 Updated by Greg Sutcliffe about 5 years ago

  • Target version set to Bug scrub

#3 Updated by Greg Sutcliffe over 4 years ago

  • Target version deleted (Bug scrub)

#4 Updated by Tomer Brisker about 1 year ago

  • Description updated (diff)
  • Category set to Compute resources - libvirt

This is a bug in fog-libvirt. Opened https://github.com/fog/fog-libvirt/pull/30 to fix it. Once fix is released we will need to make sure to update the version we package.

#5 Updated by Tomer Brisker about 1 year ago

  • Status changed from New to Assigned
  • Assigned To set to Tomer Brisker

#6 Updated by Michael Moll 8 months ago

#7 Updated by Michael Moll 8 months ago

  • Related to Bug #19692: Opening a libvirt VM console fails with fog-libvirt 0.4.0 added

#8 Updated by Michael Moll 6 months ago

  • Assigned To changed from Tomer Brisker to Michael Moll

I think this still requires https://github.com/fog/fog-libvirt/pull/43 for the array vs. string fix.

#9 Updated by The Foreman Bot 5 months ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/4784 added

#10 Updated by Michael Moll 5 months ago

  • Release set to 1.16.0

#11 Updated by Michael Moll 5 months ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF