Bug #16449

Taxonomy is detected too late during discovery

Added by Lukas Zapletal about 1 year ago. Updated about 1 year ago.

Status:Closed
Priority:Normal
Assigned To:Lukas Zapletal
Category:Facts
Target version:Team Daniel - iteration 2
Difficulty: Bugzilla link:1349364
Found in release: Pull request:https://github.com/theforeman/foreman/pull/3816
Story points-
Velocity based estimate-
Release1.13.1Release relationshipAuto

Description

The problem is that on the host the set_taxonomy from facts is only done after the facts that set the interfaces is done. And in the set of the interfaces there is a check that validates that the host.location must be included in the subnet.location. This will ofcourse fail because the host.location is then still NULL.

From https://bugzilla.redhat.com/show_bug.cgi?id=1349364

Associated revisions

Revision c49eb07f
Added by Lukas Zapletal about 1 year ago

Fixes #16449 - reordered taxonomy detection during import

Revision 860e0c7d
Added by Lukas Zapletal 12 months ago

Fixes #16449 - reordered taxonomy detection during import

(cherry picked from commit c49eb07f93f6821d7a7cad518ef537cd9ca41478)

History

#1 Updated by Lukas Zapletal about 1 year ago

  • Project changed from Discovery to Foreman
  • Category changed from Discovery plugin to Facts

This needs to be changed in core actually.

#2 Updated by The Foreman Bot about 1 year ago

  • Status changed from New to Ready For Testing
  • Assigned To set to Lukas Zapletal
  • Pull request https://github.com/theforeman/foreman/pull/3816 added

#3 Updated by Daniel Lobato Garcia about 1 year ago

  • Target version set to Team Daniel - iteration 2

#4 Updated by Lukas Zapletal about 1 year ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#5 Updated by Dominic Cleal about 1 year ago

  • Release set to 1.13.0

#6 Updated by Dominic Cleal about 1 year ago

  • Release changed from 1.13.0 to 1.13.1

Also available in: Atom PDF