Bug #16806

foreman_url template macro can't be used outside controller context

Added by Marek Hulán 6 months ago. Updated 5 months ago.

Status:Closed
Priority:Normal
Assigned To:Marek Hulán
Category:Templates
Target version:Team Marek Iteration 4
Difficulty: Bugzilla link:1374344
Found in release: Pull request:https://github.com/theforeman/foreman/pull/3919
Story points-
Velocity based estimate-
Release1.14.0Release relationshipAuto

Description

When foreman_url is used in a template which is rendered out of controller context it fails with url_for. I'm afraid it's not reproducible with pure Foreman atm but the Renderer should include url helpers so once it's included, all it's macros can be used. The issue is easily reproducible from remote execution plugin, when foreman_url is put in job template and then previewed.


Related issues

Related to Foreman - Bug #16899: All help buttons are broken Closed 10/13/2016

Associated revisions

Revision aff897f8
Added by Marek Hulán 6 months ago

Fixes #16806 - include renderer url dependencies

History

#1 Updated by Marek Hulán 6 months ago

  • Subject changed from foreman_url template macro can't be used outside controller context to foreman_url template macro can't be used outside controller context
  • Category set to Templates
  • Status changed from New to Assigned
  • Assigned To set to Marek Hulán
  • Priority changed from High to Normal

#2 Updated by The Foreman Bot 6 months ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/3919 added

#3 Updated by Marek Hulán 6 months ago

  • Target version set to Team Marek Iteration 4

#4 Updated by Marek Hulán 6 months ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#5 Updated by Dominic Cleal 6 months ago

  • Release set to 1.13.1

#6 Updated by Marek Hulán 5 months ago

  • Related to Bug #16899: All help buttons are broken added

#7 Updated by Dominic Cleal 5 months ago

  • Release changed from 1.13.1 to 1.14.0

Moving due to the issue and complex fix in #16899.

Also available in: Atom PDF