Bug #17103

Provisioning templates are not usable for location when: "All provisioning templates" is checked for that location.

Added by Marek Hulán 5 months ago. Updated 5 months ago.

Status:Closed
Priority:Normal
Assigned To:Marek Hulán
Category:Organizations and Locations
Target version:Team Marek Iteration 5
Difficulty: Bugzilla link:
Found in release: Pull request:https://github.com/theforeman/foreman/pull/3972
Story points-
Velocity based estimate-
Release1.14.0Release relationshipAuto

Description

Reporting on behalf of Petr Balogh

I am facing the issue when I use locations and have enabled: "All provisioning templates" for that location.
Seems that it doesn't work at all.

Work around which solved my problem is uncheck this checkbox and assign all provision templates for this location.

Foreman version is: 1.12.4


Related issues

Related to Foreman - Tracker #10022: Taxonomies related issues New 04/05/2015

Associated revisions

Revision 9e52b97b
Added by Marek Hulán 5 months ago

Fixes #17103 - search ignored taxonomies

When searching for ProvisioningTemplate we should respect also host
taxonomies ignore list.

History

#1 Updated by Marek Hulán 5 months ago

  • Assigned To changed from Marek Hulán to Oded Ramraz

To reproduce:

  1. create a non-admin user in org A
  2. make org A ignoring provisioning templates - in it's form go to provisioning templates and check "All provisioning templates"
  3. create OS with PXELinux template correctly associated, verify you can save a host with such OS under admin account
  4. make sure that this PXELinux template is not associated to any organization
  5. login as that user, go to host edit form, change OS to the one you've prepared, you will see "No PXELinux templates were found for this host, make sure you define at least one in your $os settings or change PXE loader"

The reason is that we do @host.update in Taxonomy.no_taxonomy_scope block but ignoring only works for correctly set Organization.current. Same applies for locations. Host#provisioning_template should respect host's taxonomies.

#2 Updated by The Foreman Bot 5 months ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/3972 added

#3 Updated by Marek Hulán 5 months ago

#4 Updated by Marek Hulán 5 months ago

  • Target version set to Team Marek Iteration 5

#5 Updated by Marek Hulán 5 months ago

  • Assigned To changed from Oded Ramraz to Marek Hulán

#6 Updated by Anonymous 5 months ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#7 Updated by Marek Hulán 5 months ago

  • Release set to 1.14.0

Also available in: Atom PDF