Feature #17155

[RFE] hammer sync-plan info should show associated products

Added by Daniel Moessner 12 months ago. Updated about 1 month ago.

Status:Closed
Priority:Normal
Assigned To:Chris Roberts
Category:Sync Plans
Target version:-
Difficulty:trivial Pull request:https://github.com/Katello/hammer-cli-katello/pull/477
Bugzilla link:1390545
Story points-
Velocity based estimate-
ReleaseKatello 3.6.0Release relationshipAuto

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1390545

Description of problem:
When creating sync plans via hammer one cannot see which products are associated with the sync plan

Version-Release number of selected component (if applicable): current
tfm-rubygem-hammer_cli-0.5.1.11-4.el7sat.noarch
tfm-rubygem-hammer_cli_foreman-0.5.1.9-1.el7sat.noarch

How reproducible:
create sync plan and associate multiple products. When running `hammer sync-plan info --<id|name> <number|name>` one cannot see which products are assigned to that sync plan

Steps to Reproduce:
1. create Sync plan, e.g.:
hammer sync-plan create --name 'SyncPlan Capsule' --enabled=true --interval daily --sync-date "2016-11-01 20:00:00"

2. attach products # hammer product set-sync-plan --name 'Red Hat Enterprise Linux Server' --sync-plan 'SyncPlan Capsule' # hammer product set-sync-plan --name 'Red Hat Software Collections for RHEL Server' --sync-plan 'SyncPlan Capsule' # hammer product set-sync-plan --name 'Red Hat Satellite Capsule' --sync-plan 'SyncPlan Capsule'

3. display info about sync plan
  1. hammer sync-plan info --name 'SyncPlan Capsule'
    ID: 1
    Name: SyncPlan Capsule
    Start Date: 2016/11/01 20:00:00
    Interval: daily
    Enabled: yes
    Description:
    Created at: 2016/11/01 10:51:11
    Updated at: 2016/11/01 10:51:11

Actual results:
associated products are not displayed

Expected results:
display associated products

Associated revisions

Revision 3ed6cee9
Added by Chris Roberts about 1 month ago

Fixes #17155 - Add products to sync plan info (#477)

History

#1 Updated by Brad Buckingham 12 months ago

  • Project changed from Foreman Remote Execution to Katello
  • Category changed from CLI to Sync Plans

#2 Updated by Eric Helms 12 months ago

  • Release set to Katello 3.3.0
  • Difficulty set to trivial

#3 Updated by Justin Sherrill 9 months ago

  • Release changed from Katello 3.3.0 to Katello Backlog

#4 Updated by Brad Buckingham 9 months ago

  • Bugzilla link set to 1390545

#5 Updated by Brad Buckingham 9 months ago

  • Target version set to Team Brad - Iteration 10

#6 Updated by Brad Buckingham 9 months ago

  • Assigned To set to Chris Roberts

#7 Updated by The Foreman Bot 9 months ago

  • Status changed from New to Ready For Testing
  • Release deleted (Katello Backlog)
  • Pull request https://github.com/Katello/hammer-cli-katello/pull/477 added

#8 Updated by Justin Sherrill 9 months ago

  • Release set to Katello Backlog

#9 Updated by The Foreman Bot 9 months ago

  • Release deleted (Katello Backlog)

#10 Updated by Eric Helms 8 months ago

  • Release set to Katello 3.4.0

#11 Updated by Brad Buckingham 8 months ago

  • Target version changed from Team Brad - Iteration 10 to Team Brad - Iteration 11

#12 Updated by Brad Buckingham 7 months ago

  • Target version changed from Team Brad - Iteration 11 to Team Brad - Iteration 12

#13 Updated by Brad Buckingham 7 months ago

  • Target version changed from Team Brad - Iteration 12 to Team Brad - Iteration 13

#14 Updated by Brad Buckingham 6 months ago

  • Target version changed from Team Brad - Iteration 13 to Team Brad - Iteration 14

#15 Updated by Justin Sherrill 6 months ago

  • Release changed from Katello 3.4.0 to Katello 3.4.1

#16 Updated by Brad Buckingham 5 months ago

  • Target version changed from Team Brad - Iteration 14 to Team Brad - Iteration 15

#17 Updated by Brad Buckingham 5 months ago

  • Target version changed from Team Brad - Iteration 15 to Team Brad - Iteration 16

#18 Updated by Eric Helms 5 months ago

  • Release changed from Katello 3.4.1 to Katello 3.4.2

#19 Updated by Eric Helms 4 months ago

  • Release changed from Katello 3.4.2 to Katello 3.4.3

#20 Updated by Brad Buckingham 4 months ago

  • Target version deleted (Team Brad - Iteration 16)

#21 Updated by Brad Buckingham 3 months ago

  • Release changed from Katello 3.4.3 to Katello Backlog

Since the PR for this issue has been sitting for quite some time, I am going the issue to the backlog and it can be re-visited once the PR is merged.

#22 Updated by Chris Roberts about 1 month ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#23 Updated by Chris Roberts about 1 month ago

  • Release changed from Katello Backlog to Katello 3.6.0

Also available in: Atom PDF