Bug #17211

Repository synchronization checks all the repos on capsule on sync status

Added by Ivan Necas 6 months ago. Updated 4 months ago.

Status:Closed
Priority:Normal
Assigned To:Ivan Necas
Category:Performance
Target version:Foreman - Team Ivan Iteration 5
Difficulty: Pull request:https://github.com/Katello/katello/pull/6435
Bugzilla link:1391704
Story points-
Velocity based estimate-
Release3.2.1Release relationshipAuto

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1391704
Description of problem: Part of the repo synchronizatoin is syncing
the rpms to capsules, if the capsule is syncing library. Due to a bug
in code, we are checking on sync status of all repositories in the
capsule (similar issue as described in
https://bugzilla.redhat.com/show_bug.cgi?id=1388296).

Version-Release number of selected component (if applicable):
sat 6.2

How reproducible:
When library is synchonized to capsules

Steps to Reproduce:
1. have a large number of repositories synced into capsule (100/1000+)
2. have a library in lifecycle environments synced to the capsule
3. synchronize the repository

Actual results:
The synchronization of repository takes much longer, than it should,
the sync task in dynflow sits in "Actions::Katello::Repository::Sync" action,
a lot of trafic between sat and capsule due to checking for status.

Expected results: The sync task is not much slower than without a
capsule present. Only check on the specific repo is happening between
the satellite and capsule.

Associated revisions

Revision b2a62a4b
Added by Ivan Necas 5 months ago

Fixes #17211 - optimize capsule sync on repo sync

Don't check on all capsule repos when syncing only one.

History

#1 Updated by Ivan Necas 6 months ago

  • Subject changed from Repository synchronization checks all the repos on capsule on sync status to Repository synchronization checks all the repos on capsule on sync status
  • Status changed from New to Assigned
  • Assigned To set to Ivan Necas
  • Target version set to Team Ivan Iteration 5

#2 Updated by Ivan Necas 6 months ago

  • Category changed from Web UI to Performance

#3 Updated by The Foreman Bot 6 months ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/6435 added

#4 Updated by Justin Sherrill 6 months ago

  • Release set to 3.2.1

#5 Updated by Ivan Necas 5 months ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#6 Updated by The Foreman Bot 5 months ago

  • Pull request https://github.com/Katello/katello/pull/6469 added

#7 Updated by Eric Helms 4 months ago

  • Pull request deleted (https://github.com/Katello/katello/pull/6469)

Also available in: Atom PDF