Bug #17585

Upgrade fail due to missing override column in filter

Added by Lukas Zapletal 5 months ago. Updated 5 months ago.

Status:Closed
Priority:Normal
Assigned To:Lukas Zapletal
Category:Discovery plugin
Target version:Plugin 7.0.1
Difficulty: Pull request:https://github.com/theforeman/foreman_discovery/pull/314
Bugzilla link:1379394
Story points-
Velocity based estimate-

Description

Hey,

this is related to #7806 and caused by https://github.com/theforeman/foreman/pull/3704/files#diff-6d280b9c3b363aeba94cea5f59333cb7 patch. It adds new column "overrides" but the discovery migration happens before the column is added.

I need to create fake objects in order to fix this. This is not related to puppet at all, this will fail in all cases.

Associated revisions

Revision 851d8788
Added by Lukas Zapletal 5 months ago

Fixes #17585 - moved permission migration after override

History

#1 Updated by Lukas Zapletal 5 months ago

  • Project changed from Foreman to Discovery
  • Category set to Discovery plugin
  • Bugzilla link set to 1379394

#2 Updated by Lukas Zapletal 5 months ago

  • Subject changed from Upgrade to Foreman develop fail due to missing override column in filter to Upgrade fail due to missing override column in filter

For the record, this will happen when upgrading 1.11 to 1.13. Will not appear when doing 1.12 to 1.13 upgrade.

#3 Updated by The Foreman Bot 5 months ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman_discovery/pull/314 added

#4 Updated by Anonymous 5 months ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#5 Updated by Lukas Zapletal 5 months ago

  • Target version set to Plugin 7.0.1

Also available in: Atom PDF