Bug #17808

Editing provisioning templates on Internet Explorer fails with Internal Server Error

Added by Amir Fefer 12 months ago. Updated 10 months ago.

Status:Closed
Priority:Normal
Assigned To:Amir Fefer
Category:Templates
Target version:Team Daniel - Iteration 9
Difficulty: Bugzilla link:1335604
Found in release: Pull request:https://github.com/theforeman/foreman/pull/4125
Story points-
Velocity based estimate-
Release1.13.4Release relationshipAuto

Description

Description of problem:
Editing provisioning templates using Internet Explorer results in an Internal Server Error.

Version-Release number of selected component (if applicable):
foreman-1.11.0.17-1.el7sat

How reproducible:
Always

Steps to Reproduce:
1. "Hosts" --> "Provisioning templates"
2. Click on any template to view the contents
3. Click "Submit" button (no need to make alterations)

Actual results:
Internal Server Error


Related issues

Related to Foreman - Bug #18587: cannot create or edit subnets and domains in IE11 Closed 02/21/2017

Associated revisions

Revision a0e1286d
Added by Amir Fefer 12 months ago

Fixes #17808 - fix 'multipart form data' IE bug

According to this bug
(https://connect.microsoft.com/IE/Feedback/Details/868498),
multipart form data is malformed if there are fields without names.
This bug has been solved within Edge browser,
however no solution is expected for IE10/IE11

Revision 4559b4c8
Added by Amir Fefer 11 months ago

Fixes #17808 - fix 'multipart form data' IE bug

According to this bug
(https://connect.microsoft.com/IE/Feedback/Details/868498),
multipart form data is malformed if there are fields without names.
This bug has been solved within Edge browser,
however no solution is expected for IE10/IE11
(cherry picked from commit a0e1286ddfced8ac90846de9e99d0b4070f0d445)

Revision 5d7da88e
Added by Amir Fefer 11 months ago

Fixes #17808 - fix 'multipart form data' IE bug

According to this bug
(https://connect.microsoft.com/IE/Feedback/Details/868498),
multipart form data is malformed if there are fields without names.
This bug has been solved within Edge browser,
however no solution is expected for IE10/IE11
(cherry picked from commit a0e1286ddfced8ac90846de9e99d0b4070f0d445)

History

#1 Updated by Dominic Cleal 12 months ago

  • Status changed from New to Need more information

Please include the details of the internal server error, the logs, the error message.

This is likely a duplicate of #13997 or #14346.

#2 Updated by The Foreman Bot 12 months ago

  • Status changed from Need more information to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/4125 added

#3 Updated by Amir Fefer 12 months ago

The key backtrace is this

[ 2016-06-01 05:24:37.4406 11358/7f372d67d700 Pool2/Implementation.cpp:1274 ]: [App 11481 stderr] [ 2016-06-01 05:24:37.4405 11706/0x00000007585730(Worker 1) utils.rb:74 ]: *** Exception EOFError in Rack application object (bad content body) (process 11706, thread 0x00000007585730(Worker 1)):
[ 2016-06-01 05:24:37.4406 11358/7f372d67d700 Pool2/Implementation.cpp:1274 ]: [App 11481 stderr]      from /opt/rh/rh-ror41/root/usr/share/gems/gems/rack-1.5.2/lib/rack/multipart/parser.rb:117:in `get_current_head_and_filename_and_content_type_and_name_and_body'
[ 2016-06-01 05:24:37.4406 11358/7f372d67d700 Pool2/Implementation.cpp:1274 ]: [App 11481 stderr]      from /opt/rh/rh-ror41/root/usr/share/gems/gems/rack-1.5.2/lib/rack/multipart/parser.rb:19:in `block in parse'
[ 2016-06-01 05:24:37.4406 11358/7f372d67d700 Pool2/Implementation.cpp:1274 ]: [App 11481 stderr]      from /opt/rh/rh-ror41/root/usr/share/gems/gems/rack-1.5.2/lib/rack/multipart/parser.rb:17:in `loop'
[ 2016-06-01 05:24:37.4406 11358/7f372d67d700 Pool2/Implementation.cpp:1274 ]: [App 11481 stderr]      from /opt/rh/rh-ror41/root/usr/share/gems/gems/rack-1.5.2/lib/rack/multipart/parser.rb:17:in `parse'
[ 2016-06-01 05:24:37.4406 11358/7f372d67d700 Pool2/Implementation.cpp:1274 ]: [App 11481 stderr]      from /opt/rh/rh-ror41/root/usr/share/gems/gems/rack-1.5.2/lib/rack/multipart.rb:25:in `parse_multipart'
[ 2016-06-01 05:24:37.4406 11358/7f372d67d700 Pool2/Implementation.cpp:1274 ]: [App 11481 stderr]      from /opt/rh/rh-ror41/root/usr/share/gems/gems/rack-1.5.2/lib/rack/request.rb:377:in `parse_multipart'
[ 2016-06-01 05:24:37.4406 11358/7f372d67d700 Pool2/Implementation.cpp:1274 ]: [App 11481 stderr]      from /opt/rh/rh-ror41/root/usr/share/gems/gems/rack-1.5.2/lib/rack/request.rb:203:in `POST'
[ 2016-06-01 05:24:37.4406 11358/7f372d67d700 Pool2/Implementation.cpp:1274 ]: [App 11481 stderr]      from /opt/rh/rh-ror41/root/usr/share/gems/gems/rack-1.5.2/lib/rack/methodoverride.rb:26:in `method_override'
[ 2016-06-01 05:24:37.4406 11358/7f372d67d700 Pool2/Implementation.cpp:1274 ]: [App 11481 stderr]      from /opt/rh/rh-ror41/root/usr/share/gems/gems/rack-1.5.2/lib/rack/methodoverride.rb:14:in `call'
[ 2016-06-01 05:24:37.4406 11358/7f372d67d700 Pool2/Implementation.cpp:1274 ]: [App 11481 stderr]      from /opt/rh/rh-ror41/root/usr/share/gems/gems/rack-1.5.2/lib/rack/runtime.rb:17:in `call'
[ 2016-06-01 05:24:37.4406 11358/7f372d67d700 Pool2/Implementation.cpp:1274 ]: [App 11481 stderr]      from /opt/rh/rh-ror41/root/usr/share/gems/gems/activesupport-4.1.5/lib/active_support/cache/strategy/local_cache_middleware.rb:26:in `call'
[ 2016-06-01 05:24:37.4406 11358/7f372d67d700 Pool2/Implementation.cpp:1274 ]: [App 11481 stderr]      from /opt/rh/rh-ror41/root/usr/share/gems/gems/actionpack-4.1.5/lib/action_dispatch/middleware/static.rb:64:in `call'
[ 2016-06-01 05:24:37.4406 11358/7f372d67d700 Pool2/Implementation.cpp:1274 ]: [App 11481 stderr]      from /opt/rh/rh-ror41/root/usr/share/gems/gems/rack-1.5.2/lib/rack/sendfile.rb:112:in `call'
[ 2016-06-01 05:24:37.4406 11358/7f372d67d700 Pool2/Implementation.cpp:1274 ]: [App 11481 stderr]      from /opt/rh/rh-ror41/root/usr/share/gems/gems/railties-4.1.5/lib/rails/engine.rb:514:in `call'
[ 2016-06-01 05:24:37.4407 11358/7f372d67d700 Pool2/Implementation.cpp:1274 ]: [App 11481 stderr]      from /opt/rh/rh-ror41/root/usr/share/gems/gems/railties-4.1.5/lib/rails/application.rb:144:in `call'
[ 2016-06-01 05:24:37.4407 11358/7f372d67d700 Pool2/Implementation.cpp:1274 ]: [App 11481 stderr]      from /opt/rh/rh-ror41/root/usr/share/gems/gems/railties-4.1.5/lib/rails/railtie.rb:194:in `public_send'
[ 2016-06-01 05:24:37.4407 11358/7f372d67d700 Pool2/Implementation.cpp:1274 ]: [App 11481 stderr]      from /opt/rh/rh

This bug apparently occurs because 'Multipart form data' IE bug - https://connect.microsoft.com/IE/Feedback/Details/868498

#4 Updated by Dominic Cleal 12 months ago

Please use one of the existing bugs in future if this is a duplicate, don't open a third.

#5 Updated by Amir Fefer 12 months ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#6 Updated by Dominic Cleal 12 months ago

  • Release set to 1.14.1

#7 Updated by Daniel Lobato Garcia 11 months ago

  • Target version set to Team Brad - Iteration 11

#8 Updated by Dominic Cleal 11 months ago

  • Target version deleted (Team Brad - Iteration 11)
  • Release changed from 1.14.1 to 1.13.4

#9 Updated by Tomer Brisker 10 months ago

  • Related to Bug #18587: cannot create or edit subnets and domains in IE11 added

#10 Updated by Daniel Lobato Garcia 10 months ago

  • Target version set to Team Daniel - Iteration 9

Also available in: Atom PDF