Bug #17922

List of repositories not updated after creating new repo

Added by Daniel Lobato Garcia 5 months ago. Updated 2 months ago.

Status:Duplicate
Priority:Normal
Assigned To:Walden Raines
Category:Repositories
Target version:Team Tom - iteration 11
Difficulty: Pull request:
Bugzilla link:
Story points-
Velocity based estimate-
ReleaseBacklogRelease relationshipAuto

Description

To reproduce:

1. Go to Content > Products
2. Choose a product
3. See the list of repositories.
4. Create a new repository by clicking on 'New repository'
5. Submit the new repository form.
6. The list of repositories remains the same as if no repo had been created.
7. You need to refresh the browser or go to another page and come back to see the new repo.


Related issues

Related to Bastion - Bug #18079: Temporarily disable table cache Closed 01/14/2017
Duplicates Bastion - Feature #18485: Re-enable the table cache Closed 02/13/2017
Blocked by Bastion - Feature #18037: Allow table to be invalidated (and removed from the table... Closed 01/11/2017

History

#1 Updated by Daniel Lobato Garcia 5 months ago

Similar behavior can be seen like this:

1. Under 'Content > Content views', choose a content view
2. Go to the puppet modules tab
3. Click on add new module
4. Choose a module and submit it.
5. The list isn't updated until you refresh the page.

#2 Updated by Justin Sherrill 5 months ago

  • Assigned To set to Walden Raines
  • Release set to 3.3.0

#3 Updated by Walden Raines 5 months ago

  • Target version set to Team Tom - iteration 9

#4 Updated by Brad Buckingham 5 months ago

I've seen similar with:

- remove content view
- issue: does not remove it from the list
- workaround: reload page

- create content view
- issue: does not add it to the list
- workaround: reload page

#5 Updated by Walden Raines 5 months ago

  • Blocked by Feature #18037: Allow table to be invalidated (and removed from the table cache) added

#6 Updated by Walden Raines 4 months ago

  • Related to Bug #18079: Temporarily disable table cache added

#7 Updated by Walden Raines 4 months ago

When http://projects.theforeman.org/issues/18079 is fixed this issue will seem to go away but will only be hidden. I will continue to track the katello side changes in this bug for when we reenable the table cache.

#8 Updated by Walden Raines 4 months ago

  • Target version changed from Team Tom - iteration 9 to Team Tom - iteration 10

#9 Updated by Justin Sherrill 4 months ago

  • Release changed from 3.3.0 to 3.4.0

#10 Updated by Walden Raines 3 months ago

  • Status changed from New to Assigned

#11 Updated by Walden Raines 3 months ago

  • Target version changed from Team Tom - iteration 10 to Team Tom - iteration 11

#12 Updated by Justin Sherrill 3 months ago

  • Release changed from 3.4.0 to Backlog

#13 Updated by Walden Raines 2 months ago

  • Status changed from Assigned to Duplicate

Duplicate of #18485.

#14 Updated by Walden Raines 2 months ago

Also available in: Atom PDF