Bug #18005

In hammer current user cannot change his own password due to current password validation

Added by Dominik Hlavac Duran 9 months ago. Updated about 1 month ago.

Status:Closed
Priority:Normal
Assigned To:Dominik Hlavac Duran
Category:Foreman commands
Target version:Foreman - Team Marek Iteration 16
Difficulty: Bugzilla link:
Found in release:1.14.0 Pull request:https://github.com/theforeman/hammer-cli-foreman/pull/289
Story points-
Velocity based estimate-
Releasehammer-cli-foreman-0.11.0Release relationshipAuto

Description

Description of problem:
In hammer current user cannot change his own password due to current password validation after foreman update in upstream;

Steps to Reproduce:
1. log to hammer as non-admin user
2. try to change user's own password

Actual results:
Current password Incorrect password

Problem is :
Missing option for current password validation


Related issues

Related to Foreman - Bug #18764: In hammer current user cannot change his own password due... Closed 03/02/2017

Associated revisions

Revision 98c00d53
Added by Dominik Hlavac Duran 3 months ago

Fixes #18005 - Fix Hammer-cli current user password update

History

#1 Updated by Marek Hulán 9 months ago

  • Assigned To set to Dominik Hlavac Duran
  • Target version set to Team Marek Iteration 9

#2 Updated by Tomáš Strachota 9 months ago

It would be nice if we could add support for entering the passwords interactively together with fixing this issue. Something like what we do for hosts:
https://github.com/theforeman/hammer-cli-foreman/blob/master/lib/hammer_cli_foreman/hosts/common_update_options.rb#L54-L57

#3 Updated by Marek Hulán 8 months ago

  • Target version changed from Team Marek Iteration 9 to Team Marek Iteration 10

#4 Updated by Marek Hulán 7 months ago

  • Target version changed from Team Marek Iteration 10 to Team Marek Iteration 11

#5 Updated by Dominik Hlavac Duran 7 months ago

  • Related to Bug #18764: In hammer current user cannot change his own password due to current password validation added

#6 Updated by The Foreman Bot 7 months ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/hammer-cli-foreman/pull/289 added

#7 Updated by Marek Hulán 6 months ago

  • Target version changed from Team Marek Iteration 11 to Team Marek Iteration 12

#8 Updated by Marek Hulán 6 months ago

  • Target version changed from Team Marek Iteration 12 to Team Marek Iteration 13

#9 Updated by Marek Hulán 5 months ago

  • Target version changed from Team Marek Iteration 13 to Team Marek Iteration 14

#10 Updated by Marek Hulán 4 months ago

  • Target version changed from Team Marek Iteration 14 to Team Marek Iteration 15

#11 Updated by Marek Hulán 3 months ago

  • Target version changed from Team Marek Iteration 15 to Team Marek Iteration 16

#12 Updated by Dominik Hlavac Duran 3 months ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#13 Updated by Tomáš Strachota about 1 month ago

  • Release set to hammer-cli-foreman-0.11.0

Also available in: Atom PDF