Bug #18123

Package conflict rubygem-multipart-post with EPEL7

Added by Klaas D 2 months ago. Updated 2 months ago.

Status:Closed
Priority:Normal
Assigned To:Dominic Cleal
Category:RPMs
Target version:-
Difficulty: Bugzilla link:
Found in release: Pull request:
Story points-
Velocity based estimate-
Release1.14.1Release relationshipAuto

Description

Hi,
I recently upgraded to katello 3.2.3/foreman 1.13 and I decided to switch to the dhcp infoblox rpm. In short, the infoblox dependencies install rubygem-faraday-0.9.1-3.el7.noarch from plugins repository and that in turn has a dependency to rubygem(multipart-post) >= 1.2.0 - so rubygem-multipart-post-1.2.0-4.el7.noarch is installed from plugins repo.
EPEL has rubygem-multipart-post-2.0.0-1.el7.noarch and therefore yum update now has a conflict.

yum output:

Resolving Dependencies
--> Running transaction check
---> Package rubygem-multipart-post.noarch 0:1.2.0-4.el7 will be updated
--> Processing Dependency: rubygem(multipart-post) >= 1.2.0 for package: rubygem-faraday-0.9.1-3.el7.noarch
--> Processing Dependency: rubygem(multipart-post) < 3 for package: rubygem-faraday-0.9.1-3.el7.noarch
---> Package rubygem-multipart-post.noarch 0:2.0.0-1.el7 will be an update
--> Finished Dependency Resolution
Error: Package: rubygem-faraday-0.9.1-3.el7.noarch (@foreman-113-plugins)
           Requires: rubygem(multipart-post) < 3
           Removing: rubygem-multipart-post-1.2.0-4.el7.noarch (@foreman-113-plugins)
               rubygem(multipart-post) = 1.2.0
           Updated By: rubygem-multipart-post-2.0.0-1.el7.noarch (epel7)
               Not found
Error: Package: rubygem-faraday-0.9.1-3.el7.noarch (@foreman-113-plugins)
           Requires: rubygem(multipart-post) >= 1.2.0
           Removing: rubygem-multipart-post-1.2.0-4.el7.noarch (@foreman-113-plugins)
               rubygem(multipart-post) = 1.2.0
           Updated By: rubygem-multipart-post-2.0.0-1.el7.noarch (epel7)
               Not found
**********************************************************************
yum can be configured to try to resolve such errors by temporarily enabling
disabled repos and searching for missing dependencies.
To enable this functionality please set 'notify_only=0' in /etc/yum/pluginconf.d/search-disabled-repos.conf
**********************************************************************

Error: Package: rubygem-faraday-0.9.1-3.el7.noarch (@foreman-113-plugins)
           Requires: rubygem(multipart-post) < 3
           Removing: rubygem-multipart-post-1.2.0-4.el7.noarch (@foreman-113-plugins)
               rubygem(multipart-post) = 1.2.0
           Updated By: rubygem-multipart-post-2.0.0-1.el7.noarch (epel7)
               Not found
Error: Package: rubygem-faraday-0.9.1-3.el7.noarch (@foreman-113-plugins)
           Requires: rubygem(multipart-post) >= 1.2.0
           Removing: rubygem-multipart-post-1.2.0-4.el7.noarch (@foreman-113-plugins)
               rubygem(multipart-post) = 1.2.0
           Updated By: rubygem-multipart-post-2.0.0-1.el7.noarch (epel7)
               Not found
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Associated revisions

Revision 045a244e
Added by Dominic Cleal 2 months ago

fixes #18123 - change multipart-post dep to RPM name from virtual

Works around a missing provides in EPEL7's multipart-post, BZ#1386644.

History

#1 Updated by Klaas D 2 months ago

workaround is to set priority on the foreman plugins repo :D

#2 Updated by Dominic Cleal 2 months ago

  • Project changed from Plugins to Packaging
  • Category set to RPMs
  • Status changed from New to Assigned
  • Assigned To set to Dominic Cleal

The issue is a missing provide in EPEL7, tracked at https://bugzilla.redhat.com/show_bug.cgi?id=1386644.

If that's not resolved soon then I can work around it in Foreman's repository.

#3 Updated by Dominic Cleal 2 months ago

  • Status changed from Assigned to Closed
  • % Done changed from 0 to 100

#4 Updated by Dominic Cleal 2 months ago

  • Release set to 1.14.1

Also available in: Atom PDF