Bug #18125

provisioning a client with 2 nics will have to default gateways

Added by Marek Hulán 7 months ago. Updated 7 months ago.

Status:Closed
Priority:Normal
Assigned To:Marek Hulán
Category:Network
Target version:Team Marek backlog
Difficulty: Bugzilla link:1376924
Found in release: Pull request:https://github.com/theforeman/community-templates/pull/345
Story points-
Velocity based estimate-
Release1.14.1Release relationshipAuto

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1376924

Description of problem:
provisioning a client with 2 nics will have to default gateways.

Version-Release number of selected component (if applicable):

Foreman 1.11+

How reproducible:

Create 2 subnets and specify the gateway for etch one then create a client and add 2 networks to point to these 2 subnets. After you kickstart the client the client will have 2 default gateways. when we create a new host we need to have an option to specify the default gateway instead to remove the gateway from the subnets.

Associated revisions

Revision 92b5ca92
Added by Marek Hulán 7 months ago

Fixes #18125 - set default gateway by primary interface

History

#1 Updated by Marek Hulán 7 months ago

  • Subject changed from provisioning a client with 2 nics will have to default gateways to provisioning a client with 2 nics will have to default gateways
  • Assigned To set to Marek Hulán
  • Target version set to Team Marek backlog

The issue is not the fact we have multiple gateways but that we don't have control over which default gateway wins. I didn't find a way to specify custom metric in dhcpd and it probably make sense to define only one default gateway based on which interface is primary. Therefore we can adjust the configuring template so it defines DEFROUTE accordingly. I don't know how this works on deb based systems, but so far no one reported issues there.

#2 Updated by The Foreman Bot 7 months ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/community-templates/pull/345 added

#3 Updated by Anonymous 7 months ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#4 Updated by Dominic Cleal 7 months ago

  • Release set to 1.14.1

Also available in: Atom PDF