Bug #18316

Rerun job with failed hosts fails with "Stack level too deep" in the log.

Added by Shimon Shtein 11 months ago. Updated 7 months ago.

Status:Closed
Priority:Normal
Assigned To:Shimon Shtein
Category:-
Target version:Foreman - Team Ivan Iteration 13
Difficulty: Pull request:https://github.com/theforeman/foreman_remote_execution/pull/226
Bugzilla link:1406489
Story points-
Velocity based estimate-
Releaseforeman_remote_execution 1.3.1Release relationshipAuto

Description

Started as a reproducer for https://bugzilla.redhat.com/show_bug.cgi?id=1406489
The test didn't reproduce the issue, but it's already written.

Associated revisions

Revision 68719465
Added by Shimon Shtein 8 months ago

Fixes #18316 - Changed scoped_search query to :in for hosts enum

When asking to target a specific set of hosts (like in case of failed
hosts), a `name = X or name = Y...` query was generated. This query
caused a very deep stack recursion in scoped_search AST. This commit
changes the query to `name ^ (X, Y...)` that will not require the same
treatment in AST.

History

#1 Updated by The Foreman Bot 11 months ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman_remote_execution/pull/226 added

#2 Updated by Ivan Necas 11 months ago

  • Target version set to Team Ivan Iteration 10
  • Bugzilla link set to 1406489

#3 Updated by Shimon Shtein 9 months ago

After an investigation, I was able to reproduce the issue. The problem was in query syntax: originally rerun query was generating a huge OR statement like: "name = X or name = Y...". This query could not be loaded into AST inside scoped_search without blowing up the stack.

#4 Updated by Shimon Shtein 9 months ago

  • Subject changed from Add test for job invocation UI controller to Rerun job with failed hosts fails with "Stack level too deep" in the log.

#5 Updated by Ivan Necas 8 months ago

  • Target version changed from Team Ivan Iteration 10 to Team Ivan Iteration 13

#6 Updated by Ivan Necas 8 months ago

  • Status changed from Ready For Testing to Closed

#7 Updated by Ivan Necas 7 months ago

  • Release set to foreman_remote_execution 1.3.1

Also available in: Atom PDF