Bug #18381

PXE loader attribute does not work with host group inheritance

Added by Marek Hulán 10 months ago. Updated 3 months ago.

Status:Closed
Priority:Normal
Assigned To:Swapnil Abnave
Category:TFTP
Target version:Team Anurag Iteration 12
Difficulty: Bugzilla link:1483948
Found in release: Pull request:https://github.com/theforeman/foreman/pull/4260
Story points-
Velocity based estimate-
Release1.16.0Release relationshipAuto

Description

reproducing steps:

1. Define a host group A where you set OS and configure "PXELinux BIOS" (the value does not matter)
2. Define sub host group B, set A as a parent
3. The PXE loader attribute does not inherit anything and prints Inherited parent (no value)

it should show "Inherited value (PXELinux BIOS)" but it does not work. The reason is that other attributes respecting inheritance combines two methods. For example `ptable_id` only return uninherited value while `ptable` works with inheritace. Since pxe_loader is not relation but simple attribute this does not work.

I started to work on the fix but didn't have time to finish it, feel free to inspire at here, the host group form works, but when it's applied in host form, the pxe_loader remains blank.

A workaround I had to do was assigning the pxeloader in all child host groups.

Present probably since 1.13+, see #12634


Related issues

Related to Foreman - Feature #12634: New HW Model flag pxe_loader in UI/API Closed 11/30/2015
Duplicated by Foreman - Bug #18493: PXE loader is not inherited from parent hostgroup Duplicate 02/14/2017
Duplicated by Foreman - Bug #19560: pxe loader not inherited from parent hostgroup Duplicate 05/16/2017

Associated revisions

Revision b8b00a96
Added by Swapnil Abnave 7 months ago

Fixes #18381 - PXE loader show inherited value in host/hostgroup

History

#1 Updated by Marek Hulán 10 months ago

  • Related to Feature #12634: New HW Model flag pxe_loader in UI/API added

#2 Updated by Marek Hulán 10 months ago

  • Description updated (diff)

#3 Updated by Swapnil Abnave 10 months ago

I started to work on the fix but didn't have time to finish it, feel free to inspire at here, the host group form works, but when it's applied in host form, the pxe_loader remains blank.

I'll try this.

Thanks!

#4 Updated by Swapnil Abnave 10 months ago

  • Assigned To set to Swapnil Abnave
  • Target version set to Team Anurag Iteration 9

#5 Updated by The Foreman Bot 10 months ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/4260 added

#6 Updated by Dominic Cleal 9 months ago

  • Duplicated by Bug #18493: PXE loader is not inherited from parent hostgroup added

#7 Updated by Swapnil Abnave 8 months ago

  • Target version changed from Team Anurag Iteration 9 to Team Anurag Iteration 12

#8 Updated by Swapnil Abnave 7 months ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#9 Updated by Dominic Cleal 6 months ago

  • Duplicated by Bug #19560: pxe loader not inherited from parent hostgroup added

#10 Updated by Filip Brychta 4 months ago

I can still see this in foreman 1.15.2

#11 Updated by Marek Hulán 4 months ago

  • Release set to 1.16.0

The commit https://github.com/theforeman/foreman/commit/b8b00a962d4f1a8ba21877896254845599474946 was merged in develop branch, it means it will be part of new minor release. Setting 1.16.0.

#12 Updated by Daniel Lobato Garcia 3 months ago

  • Bugzilla link set to 1483948

Also available in: Atom PDF