Bug #18459

[RFE] - Applying Erratum to a client, Cancel and Next button only visible while scrolling through the entire list of content-hosts

Added by Walden Raines about 1 month ago. Updated about 1 month ago.

Status:Closed
Priority:Normal
Assigned To:Walden Raines
Category:Errata Management
Target version:Team Tom - iteration 10
Difficulty:easy Pull request:https://github.com/Katello/katello/pull/6605
Bugzilla link:1420711
Story points-
Velocity based estimate-
Release3.4.0Release relationshipAuto

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1420711
Description of problem:
[RFE] - Applying Erratum to a client, Cancel and Next button only visible while scrolling through the entire list of content-hosts

Version-Release number of selected component (if applicable):
Red Hat Satellite 6.2.7

How reproducible:
100%

Steps to Reproduce:

1) Have a large number of Content Hosts registered to Satellite 6

2) Try to apply an erratum by going to Content --> Errata --> Select an Errata --> click on Apply Errata --> select a single content-host

3) You need to scroll through the entire content-hosts to reach to the bottom to click on the Next button.

Actual results:
To apply erratum, customer has to scroll through all the content-hosts which would cause inconvenience if you have more number of content-hosts registered.

Expected results:
Cancel and Next Button Should be moved out of Content Hosts display frame.

Additional info:


Related issues

Related to Katello - Refactor #17352: Incremental updates should use the angular-patternfly wizard New 11/15/2016

Associated revisions

Revision 3527c140
Added by Walden Raines about 1 month ago

Fixes #18459: fix incremental update select content host display

The next and cancel buttons for incremental update were being displayed
below the table and if there were a lot of content hosts the user would
have to scroll through the entire list of content hosts (due to infinite
scrolling) in order to get to the buttons. This commit temporarily
moves the next/cancel buttons to the top of the table until this entire
workflow can be replaced by the angular-patternfly wizard.

http://projects.theforeman.org/issues/18459

History

#1 Updated by Walden Raines about 1 month ago

  • Assigned To set to Walden Raines
  • Target version set to Team Tom - iteration 10

#2 Updated by Walden Raines about 1 month ago

This will be invalidated by the use of the angular-patternfly wizard (http://projects.theforeman.org/issues/17352) but for now we should just move the next and cancel buttons for incremental update to the top of the table so they are more easily accessible.

#3 Updated by Walden Raines about 1 month ago

  • Related to Refactor #17352: Incremental updates should use the angular-patternfly wizard added

#4 Updated by Walden Raines about 1 month ago

  • Category set to Errata Management
  • Difficulty set to easy

#5 Updated by The Foreman Bot about 1 month ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/6605 added

#6 Updated by Eric Helms about 1 month ago

  • Release set to 3.4.0

#7 Updated by Walden Raines about 1 month ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF