Bug #18468

Network list not shown when creating a compute profile on a libvirt compute resource

Added by Daniel Lobato Garcia 8 months ago. Updated 8 months ago.

Status:Closed
Priority:Normal
Assigned To:Sebastian Gräßl
Category:Compute resources
Target version:Team Daniel - Iteration 9
Difficulty: Bugzilla link:1394817
Found in release: Pull request:https://github.com/theforeman/foreman/pull/4277, https://github.com/theforeman/foreman/pull/4282
Story points-
Velocity based estimate-
Release1.14.2Release relationshipAuto

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1394817
Description of problem:
When creating one new computer profile using as computer resource one libvirt connection, is not possible see the Network available in dropdown menulist, only after submit and open again we can see the network available to this computer resource / provider.

Version-Release number of selected component (if applicable):
6.2.4

How reproducible:
100%

Steps to Reproduce:
1. Create one new libvirt computer resource
2. Infrastructure - Computer Profiles - New Computer Profile - <define name> / submit - <select libvirt computer resource>
3. In Network interfaces section, it's possible to see Network type, Network and NIC type, feel free to change Network type, in Network field still as text box.
4. Click on Submit
5. Reopen the same computer profile and check again the Network field, now it's possible to select via dropdown menu list.

Actual results:
text box

Expected results:
dropdown menu list with network availables

Additional info:

Associated revisions

Revision ec7fc1bd
Added by Sebastian Gräßl 8 months ago

Fixes #18468 - Include JS in libvirt compute profile form

When the form is loaded via XHR the needed JavaScript
is not loaded and selecting of certain attributes fail.

Revision 8c1eb62e
Added by Dominic Cleal 8 months ago

refs #18468 - move compute_resources JS to compute profile index

The CR JS should always be ready and loaded on the compute profile
index, as the new attributes form is rendered into the existing page
after the profile is created.

Because the new attributes form is loaded via the two-pane #content
replacement, the additional JavaScript tag specified in
compute_profiles/show is not automatically loaded into the page.

This fixes the issue for all compute resources, not only Libvirt. It
also uses the `javascript` header to properly track the asset with
Turbolinks so it's unloaded later.

Revision 471ccb7c
Added by Sebastian Gräßl 8 months ago

Fixes #18468 - Include JS in libvirt compute profile form

When the form is loaded via XHR the needed JavaScript
is not loaded and selecting of certain attributes fail.
(cherry picked from commit ec7fc1bd9f6ec77a90287f77092ad1f57fc92790)

Revision 2f8e5a95
Added by Dominic Cleal 8 months ago

refs #18468 - move compute_resources JS to compute profile index

The CR JS should always be ready and loaded on the compute profile
index, as the new attributes form is rendered into the existing page
after the profile is created.

Because the new attributes form is loaded via the two-pane #content
replacement, the additional JavaScript tag specified in
compute_profiles/show is not automatically loaded into the page.

This fixes the issue for all compute resources, not only Libvirt. It
also uses the `javascript` header to properly track the asset with
Turbolinks so it's unloaded later.
(cherry picked from commit 8c1eb62ebea57fdfa0d153063eccce6756b0ebc7)

History

#1 Updated by Dominic Cleal 8 months ago

  • Subject changed from It's not possible see Network when creating one new compute profile / libvirt computer resource to Network list not shown when creating a compute profile on a libvirt compute resource
  • Category set to Compute resources

#2 Updated by Sebastian Gräßl 8 months ago

  • Assigned To set to Sebastian Gräßl

#3 Updated by The Foreman Bot 8 months ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/4277 added

#4 Updated by Anonymous 8 months ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#5 Updated by The Foreman Bot 8 months ago

  • Pull request https://github.com/theforeman/foreman/pull/4282 added

#6 Updated by Dominic Cleal 8 months ago

  • Release set to 1.14.2

#7 Updated by Daniel Lobato Garcia 8 months ago

  • Target version set to Team Daniel - Iteration 9

Also available in: Atom PDF