Tracker #18471

Drop Puppet 3 support (installer modules)

Added by Ewoud Kohl van Wijngaarden about 1 year ago. Updated 7 months ago.

Status:Closed% Done:

0%

Priority:Normal
Assigned To:-
Category:Foreman modules
Target version:-
Difficulty: Bugzilla link:
Found in release:
Story points-
Velocity based estimate-
Release1.16.0Release relationshipAuto

Description

Officially Puppet 3 is already EOL since 1-1-2017. Both Puppetlabs and Voxpupuli (our only dependencies) are dropping Puppet 3 support as well so soon we'll need to start pinning on older versions.

This is a tracker bug aiming to deprecate Puppet 3 in our installer (including its modules) for Foreman 1.15 and drop support for 1.16.


Related issues

Related to Installer - Feature #18472: Add an option to upgrade puppet 3 to puppet 4 in the inst... Assigned 02/13/2017

History

#1 Updated by Ewoud Kohl van Wijngaarden about 1 year ago

  • Blocked by Feature #18472: Add an option to upgrade puppet 3 to puppet 4 in the installer added

#2 Updated by Ewoud Kohl van Wijngaarden 11 months ago

  • Status changed from New to Ready For Testing

Given all our modules dropped Puppet 3 and are using Puppet 4 I think we can close this. Looks like I don't have permission to though.

#3 Updated by Dominic Cleal 11 months ago

  • Blocked by deleted (Feature #18472: Add an option to upgrade puppet 3 to puppet 4 in the installer)

#4 Updated by Dominic Cleal 11 months ago

  • Related to Feature #18472: Add an option to upgrade puppet 3 to puppet 4 in the installer added

#5 Updated by Dominic Cleal 11 months ago

  • Category set to Foreman modules
  • Status changed from Ready For Testing to Closed
  • Release set to 1.16.0

#6 Updated by Daniel Lobato Garcia 7 months ago

  • Subject changed from Drop Puppet 3 support to Drop Puppet 3 support (installer modules)

Also available in: Atom PDF