Bug #18518

New Container wizard is missing proper feedback on image search error

Added by Sebastian Gräßl about 1 month ago. Updated 8 days ago.

Status:Ready For Testing
Priority:Normal
Assigned To:Sebastian Gräßl
Category:Plugin (foreman_docker)
Target version:Foreman - Team Daniel - Iteration 9
Difficulty: Pull request:https://github.com/theforeman/foreman-docker/pull/186, https://github.com/theforeman/foreman-docker/pull/183
Bugzilla link:1190237

Description

When creating a new container, image search is failing but not giving any user feedback. Also when trying to finish the wizard any feedback is given and the page just not work.

How reproducible:
Aways when an error or failure happens.

Steps to Reproduce:
1. Go to Containers > New Container
2. Select a Compute Resource and go to next step
3. Try to search some image, if an error happens no feedback will be shown
4. In order to test the finish step, just fill the image and tag with any value and proceed to next step
5. Fill the required fields and proceed
6. Try to finish the wizard if it is not able to save the new container no feedback will be given

Actual results:
No error feedback is given

Expected results:
Show some feedback, like an error alert, saying that something went wrong. A message is returned but is only visible when using the Developers Tools console.

History

#1 Updated by The Foreman Bot about 1 month ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman-docker/pull/183 added

#2 Updated by Daniel Lobato Garcia about 1 month ago

  • Target version set to Team Daniel - Iteration 9

#3 Updated by The Foreman Bot 8 days ago

  • Pull request https://github.com/theforeman/foreman-docker/pull/186 added

Also available in: Atom PDF