Bug #18682

Offload upload package profile to dynflow executor

Added by Shimon Shtein 6 months ago. Updated 4 months ago.

Status:Closed
Priority:Normal
Assigned To:Shimon Shtein
Category:-
Target version:Foreman - Team Ivan Iteration 12
Difficulty: Pull request:https://github.com/Katello/katello/pull/6640
Bugzilla link:1434040
Story points-
Velocity based estimate-
ReleaseKatello 3.4.0Release relationshipAuto

Description

Right now the controller parses packages JSON and plans the action. The problem is that the planning phase is quite long, so the action stays in memory for a long time. This causes GC to mark the JSON as old, so this parameter will stay in memory for a long time causing memory fragmentation.

Associated revisions

Revision a968d292
Added by Shimon Shtein 4 months ago

Fixes #18682 - Offloaded upload package task to dynflow executor

History

#1 Updated by The Foreman Bot 6 months ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/6640 added

#2 Updated by Eric Helms 6 months ago

  • Release set to Katello 3.4.0

#3 Updated by Ivan Necas 5 months ago

  • Target version set to Team Ivan Iteration 12

#4 Updated by Mike McCune 5 months ago

  • Bugzilla link set to 1434040

#5 Updated by Shimon Shtein 4 months ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF