Bug #18812

Content hosts show red untitled status from webui yet subscribed from command line, as well as green fully entitled with no subscription attached

Added by Chris Roberts 6 months ago. Updated 2 months ago.

Status:Closed
Priority:High
Assigned To:Chris Roberts
Category:Installer
Target version:Team Brad - Iteration 12
Difficulty:easy Pull request:https://github.com/Katello/puppet-qpid/pull/66, https://github.com/Katello/puppet-qpid/pull/51, https://github.com/Katello/puppet-katello/pull/168
Bugzilla link:1371605
Story points-
Velocity based estimate-
ReleaseKatello 3.4.0Release relationshipAuto

Description

copied from BZ:

Associated revisions

Revision 151c4071
Added by Chris Roberts 5 months ago

Refs #18812 - Update bindings on event queue (#168)

Refs #18812 - Update bindings on event queue

Revision ba8aae68
Added by Chris Roberts 5 months ago

Fixes #18812 - Add exec to delete unfiltered queue (#175)

Fixes #18812 - Add exec to delete unfiltered queue

History

#1 Updated by Chris Roberts 6 months ago

Description of problem:

When looking at the webui, under hosts > content hosts > then searching for

subscription_status != valid

all red content hosts show up, yet a number of these show errata/security updates in the webui, as well as can yum update

The below commands all confirm that the system is fully entitled.

  1. subscription-manager status
  1. subscription-manager list --consumed

Running a # subscription-manager refresh does not update the webui.

content hosts are using derived skus ( virt-who set up correctly)

Version-Release number of selected component (if applicable):

How reproducible: 100% in customers environment

Steps to Reproduce:
1. register system, with or without activation key
2. subscription-manager attach --auto or attach using pool id to valid subscription
3. # subscription-manager status shows fully entitled # yum update is successful.
4. confirmed not using 24 hour sku, 100% using proper subscription from hosts
5. subscription-manager fresh

Actual results: content host shows red, and unentitled

Expected results: content hosts should show green with have a valid subscription. Same as hosts that have no subscription attached should be red.

Additional info: Satellite is also showing incorrect colors for content hosts that have only been registered and show no subscription attached.

#2 Updated by The Foreman Bot 6 months ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello-installer/pull/487 added

#3 Updated by Chris Roberts 5 months ago

  • Pull request https://github.com/Katello/puppet-katello/pull/168 added

#4 Updated by Chris Roberts 5 months ago

  • Pull request https://github.com/Katello/puppet-qpid/pull/51 added

#5 Updated by Justin Sherrill 5 months ago

  • Release set to Katello 3.4.0

#6 Updated by Brad Buckingham 5 months ago

  • Target version changed from Team Brad - Iteration 11 to Team Brad - Iteration 12

#7 Updated by Anonymous 5 months ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#8 Updated by Chris Roberts 3 months ago

  • Pull request deleted (https://github.com/Katello/katello-installer/pull/487)

#9 Updated by Chris Roberts 2 months ago

  • Pull request https://github.com/Katello/puppet-qpid/pull/66 added

Also available in: Atom PDF