Bug #18971

Custom pools deleted after importing or refreshing a manifest

Added by John Mitsch 9 months ago. Updated 7 months ago.

Status:Resolved
Priority:Urgent
Assigned To:Andrew Kofink
Category:Candlepin
Target version:Team Brad - Iteration 15
Difficulty: Pull request:
Bugzilla link:1452330
Story points-
Velocity based estimate-
ReleaseKatello 3.4.0Release relationshipAuto

Description

This is a transient bug, not sure what conditions one needs to recreate this.

History

#1 Updated by John Mitsch 9 months ago

Looks like its either the first product created or products created before a manifest

#2 Updated by John Mitsch 9 months ago

  • Category set to Candlepin
  • Assigned To set to John Mitsch

#3 Updated by John Mitsch 9 months ago

  • Target version set to Team Brad - Iteration 12

#4 Updated by Brad Buckingham 9 months ago

  • Target version changed from Team Brad - Iteration 12 to Team Brad - Iteration 13

#5 Updated by Walden Raines 8 months ago

  • Priority changed from Normal to High
  • Release set to Katello 3.4.0

#6 Updated by Walden Raines 8 months ago

This seems like a pretty serious usability issue for a new user and would result in confusion.

#7 Updated by John Mitsch 8 months ago

I was unable to reproduce this on a new dev environment. Can someone else confirm that the first product created on a new environment (before importing a manifest) creates a subscription?

#8 Updated by John Mitsch 8 months ago

  • Target version changed from Team Brad - Iteration 13 to Team Brad - Backlog

#9 Updated by Justin Sherrill 8 months ago

  • Assigned To changed from John Mitsch to Andrew Kofink

#10 Updated by Justin Sherrill 7 months ago

  • Release changed from Katello 3.4.0 to Katello 3.4.1

#11 Updated by Justin Sherrill 7 months ago

  • Subject changed from Subscriptions not created for custom products to Custom subscription deleted after importing a manifest

Steps to reproduce:

1. install a fresh katello
2. Create a product
3. visit the RH Subscriptions page and see that the subscription is there
4. Import a manifest
5. Visit the RH subscription page and see that the custom subscription is missing

Also of note a 'pool.deleted' event is kicked off via the event listener, so it seems candlepin is causing this.

#12 Updated by Justin Sherrill 7 months ago

  • Priority changed from High to Urgent
  • Target version changed from Team Brad - Backlog to Team Brad - Iteration 15

#13 Updated by Justin Sherrill 7 months ago

  • Bugzilla link set to 1452330

#14 Updated by Justin Sherrill 7 months ago

  • Subject changed from Custom subscription deleted after importing a manifest to Custom pools deleted after importing a manifest

#15 Updated by Justin Sherrill 7 months ago

  • Subject changed from Custom pools deleted after importing a manifest to Custom pools deleted after importing or refreshing a manifest

#16 Updated by Justin Sherrill 7 months ago

  • Release changed from Katello 3.4.1 to Katello 3.4.0

#17 Updated by Justin Sherrill 7 months ago

  • Status changed from New to Resolved

This is now resolved in 3.4.0 via a candlepin update

Also available in: Atom PDF