Bug #19146

World invalidation can fail, when execution plans are invalid

Added by Ivan Necas 24 days ago. Updated 18 days ago.

Status:Closed
Priority:Normal
Assigned To:Ivan Necas
Category:Dynflow
Target version:Foreman - Team Ivan Iteration 13
Difficulty: Bugzilla link:1390931
Found in release: Pull request:https://github.com/Dynflow/dynflow/pull/227
Story points-
Velocity based estimate-
Releasedynflow-0.8.24Release relationshipAuto

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1390931
Description of problem:
Under some circumstances (such as manually deleting data from dynflow_execution_steps),

Version-Release number of selected component (if applicable):

How reproducible:
under special circumstances

Steps to Reproduce:
1. trigger a task
2. force kill the dynflow executor process
3. while the task is runnint, delete data from dynflow manually (CAUTION: THIS IS BY NO MEANS A RECOMMENDED WAY OF DEALING WITH TASKS - FOR REPRODUCER PURPOSES ONLY):
psql foreman
delete from foreman_tasks_tasks;
delete from foreman_tasks_locks;
delete from dynflow_steps;
delete from dynflow_actions;
exit
note we are not deleting execution plan
4. restart the foreman-tasks service

Actual results:
in logs, there is invalid worlds found message, where at the terminated world uuid, there is invalid worlds found {"a97cd2c2-a86b-4309-aa0c-edd7ed1c6c9f"=>"Value (NilClass) '' is not any of: Dynflow::ExecutionPlan::Steps::Abstract." The killed world is not able to recover properly.

Excpeted results:
The issue is logged, but the world is invalidated properly and the old world doesn't stay in the worlds registry (/foreman_tasks/dynflow/worlds)


Related issues

Related to foreman-tasks - Bug #19147: Handle issues with loading execution_plan Closed 04/03/2017
Copied from foreman-tasks - Bug #17177: World invalidation can fail, when execution plans are mis... Closed 11/02/2016

History

#1 Updated by Ivan Necas 24 days ago

  • Copied from Bug #17177: World invalidation can fail, when execution plans are missing added

#2 Updated by Ivan Necas 24 days ago

  • Status changed from New to Assigned

#3 Updated by Ivan Necas 24 days ago

  • Bugzilla link deleted (1390931)

#4 Updated by Ivan Necas 24 days ago

  • Description updated (diff)

#5 Updated by Ivan Necas 24 days ago

  • Status changed from Assigned to Ready For Testing
  • Bugzilla link set to 1390931
  • Pull request https://github.com/Dynflow/dynflow/pull/227 added

#6 Updated by Ivan Necas 24 days ago

  • Related to Bug #19147: Handle issues with loading execution_plan added

#7 Updated by Ivan Necas 24 days ago

  • Target version set to Team Ivan Iteration 13

#8 Updated by Adam Ruzicka 18 days ago

  • Status changed from Ready For Testing to Closed

Closing since github PR got merged.

#9 Updated by Ivan Necas 18 days ago

  • Category set to Dynflow
  • Release set to dynflow-0.8.24

Also available in: Atom PDF